06 Clutch...Bad? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 08-07-2006, 05:01 PM
WRXtuners Member
 
WRXbkaus's Avatar
 
Join Date: Jan 2006
Location: California
Posts: 30
Images: 5
WRXbkaus is an unknown
06 Clutch...Bad?

I experienced my first problem with my 06 yesterday.

I had just left the xgames and flipped a U-turn, and I smelled my clutch burning.
Stopped at the light with it in neutral. And when I was ready to go, I was locked out of all of my gears (1-5, and R).

I had thought my clutch was fried. It is my daily driver, I am not very hard on it. Right now only 12K miles.

Took to subaru,.... Monday they said everything was working properly and that there was no problems.

Now I have to drive it untill my clutch breaks again.
WRXbkaus is offline  
Sponsored Links
Advertisement
 
#2 Old 08-07-2006, 07:30 PM
WRXpert
 
LiL Shoaf's Avatar
 
Join Date: Jun 2005
Location: Pennsylvania
Posts: 1,810
Images: 2
LiL Shoaf is more helpful than not
Send a message via AIM to LiL Shoaf Send a message via Yahoo to LiL Shoaf
More then likely you did the same thing I did at the Drags this weekend.. If you managed to over heat the clutch disk it will cause the situation you are describing.. I grabbed 2nd gear and my clutch slipped through 2nd and then I had to wait for 30 minutes after wards before it cooled enough that I could get into reverse..

02 WRX.. "It's fun when it runs.. Problem is that it hardly ever does..."
LiL Shoaf is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On