03 WRX STI boost leak, bad controller? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 06-06-2013, 09:52 PM
WRXtuners Member
 
Join Date: Jun 2013
Location: Virginia
Posts: 1
Beeken88 is an unknown
03 WRX STI boost leak, bad controller?

I have a 2003 Subaru Impreza WRX with a STI engine that I bought as is. Everything was fine until I washed engine it runs good until I push the pedle to the floor at any rpm. I believe its a boost leak or maybe a bad manual controller from what I have looked up. I just would like to know what would you all check first? I would greatly appreciate any help~
Beeken88 is offline  
Sponsored Links
Advertisement
 
#2 Old 06-07-2013, 08:25 AM
Moderator
 
mosc's Avatar
 
Join Date: Mar 2005
Location: Pennsylvania
Posts: 6,442
Images: 7
mosc is a helpful contributing member
Garage
make sure all the vaccuum lines are tight. If that doesn't fix it do a leak test.

You also don't seem to know what's under your hood? Highly unlikely it's a complete STi engine. That would require new ECU, even new pedals (STi is drive by wire). This then makes it hard to give you advice on your boost control system because it's an unknown. Is it stock-like? 3-port BSC? MBC with ECU control? What?

04 STi 16G powered lagless fun
04 WRX: SOLD
mosc is offline  
Reply


Currently Active Users Viewing This Thread: 3 (0 members and 3 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On