Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   03 wrx overheating and oil smell (http://www.wrxtuners.com/forums/f72/03-wrx-overheating-oil-smell-39825/)

SilentJay18 09-30-2013 09:12 PM

03 wrx overheating and oil smell
 
About 5 months ago I bought an 03 wrx with122,000 on it. I took it up to the mountains about a month ago and once I got up there noticed that it had started to overheat once I got the where I was. I looked into the coolant reservoir and noticed that it was pretty much empty. I topped it off and it ran great until about a week later when just driving it in town the temp gauge started to climb. Again I toped off the coolant and it was fine. And now it happens about every week. I have also started to smell a strong smell of oil after getting on it. It randomly will miss fire when I start it but stops right away. I don't know if they are all connected or not but from the little mechanical experience u have it sounds like a head gasket to me but I don't know much about these cars so I was wondering if anyone has any other suggestion before I pull the motor apart. Any help wlll b greatly appreciated thank.

pzr2874 10-01-2013 08:07 AM

Do a compression check first.

So after a drive and you park it, there are no fluids on the ground?

Have you changed the oil to see if it's "frothy/milky?"

boo-key 10-01-2013 08:51 AM

I think Tyler had a similar problem.

06_hawk_eye 10-01-2013 08:55 AM

What happened with mine is that my rad was cracked along the top. Have a cooling system pressure test done and see if there is any leaks. My temp never rose those I just didn't have any heat at idle. Only when reved up.


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com App[/url][/color]

psinuse 10-01-2013 09:50 AM

Was the water pump replaced when the timing belt was done? the weep hole on the water pump is in a bad place and if the water pump is bad its gonna leak coolant that you won't find and at idle will over heat...

SilentJay18 10-01-2013 10:02 AM

A couple weeks ago after sitting at an angle for about 3 days I came out and there was some coolest on the ground but I couldn't see where it was coming from. I don't know if the trimming belt has been changed. The carfax and the dealership I bought it from couldn't tell me if it had. I'm going to do an oil change and take off the timing belt cover this weekend and see if it has or not.

turmic 10-01-2013 10:52 AM

Where is Bob? ROFL I had too...

SilentJay18 10-02-2013 12:23 AM

It overheated again today. I had to burp it again to get air out of the system. This is the second time that I have had to do this. I did it a month ago when it happened the first time and now again.

06_hawk_eye 10-02-2013 06:30 AM

[quote=SilentJay18;365329]It overheated again today. I had to burp it again to get air out of the system. This is the second time that I have had to do this. I did it a month ago when it happened the first time and now again.[/quote]

If it keeps getting air into the system that most likely means there a leak. A simply pressure test will help you out alot. Turn the heat on high and let me know if you have heat?


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com App[/url][/color]

SilentJay18 10-02-2013 10:13 AM

I didn't have any heat before I burped it but after it was nice at hot.

SilentJay18 10-05-2013 11:17 AM

I got a pressure tester on it today and there was a hole in the upper radiator hose that was leaking right on the motor so I couldn't see it. Thank you all for all your help and suggestions

06_hawk_eye 10-05-2013 11:38 AM

[quote=SilentJay18;367929]I got a pressure tester on it today and there was a hole in the upper radiator hose that was leaking right on the motor so I couldn't see it. Thank you all for all your help and suggestions[/quote]

Glad we could help my friend


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com App[/url][/color]

pzr2874 10-05-2013 09:53 PM

[quote=06_hawk_eye;367945]Glad we could help my friend


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com App[/url][/color][/quote]

Did you do this?

06_hawk_eye 10-05-2013 10:06 PM

[quote=pzr2874;368297]Did you do this?[/quote]

Do what?


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com App[/url][/color]


All times are GMT -5. The time now is 01:25 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome