03 wrx cel on for awhile - Page 3 - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
#31 Old 06-05-2009, 09:30 PM
WRXtuners Member
 
pb-king07's Avatar
 
Join Date: Mar 2008
Location: Washington
Posts: 135
Images: 2
pb-king07 is an unknown
+ 1 V24 If you don't want the help then don't ask. Im sure your BOV is messing with the cars air/fuel really bad. I had a BOV on my car for 2 miles the car ran like crap. ya the BOV sounded cool but it is not worth having it on there. if you have the money for a WRX/STI then don't go cheap on parts. you did not buy a cheap car so why buy cheap parts. but thats just IMO. its your car and your money
pb-king07 is offline  
Sponsored Links
Advertisement
 
#32 Old 06-05-2009, 09:58 PM
WRXtuners Member
 
Join Date: May 2009
Location: Pennsylvania
Posts: 19
03wrx84 is an unknown
i bought the car used , exhaust , intake bov etc already on . i do want help , just didnt feel it would be necessary i see wrx / sti all the time with the same shit running fine .
03wrx84 is offline  
#33 Old 06-06-2009, 03:10 AM
WRXtuners Member
 
03 CrazyTaxi's Avatar
 
Join Date: Jan 2006
Location: Missouri
Posts: 728
Images: 4
03 CrazyTaxi is known to be trustworthy and helpful 03 CrazyTaxi is known to be trustworthy and helpful
Send a message via MSN to 03 CrazyTaxi Send a message via Yahoo to 03 CrazyTaxi
Not all intakes are created the same. Statement works for the BOVs as well. Because the WRX and STi are MAF cars, they tend not to like BOVs. Unless you go through the trouble of relocating the MAF to the throttle body, I'd recommend removing the BOV in favor of the stock BPV or a 50/50 type. As for the intake, they tend to mess with the MAF voltage readings. This is something that a tune would take care of.

VF34'd Corvette Killer aka Doug
03 CrazyTaxi is offline  
#34 Old 06-06-2009, 08:04 AM
WRXtuners Member
 
Join Date: May 2009
Location: Pennsylvania
Posts: 19
03wrx84 is an unknown
ok thanks
03wrx84 is offline  
#35 Old 06-14-2009, 04:19 PM
WRXtuners Member
 
Join Date: May 2009
Location: Pennsylvania
Posts: 19
03wrx84 is an unknown
okay thanks for your help . PROBLEM FIXED . the cel was b/c there was a small crack in the line running to the waste gate . the reason it was running rough was my MAF sensor got wet . took the car to subaru paid a little , but after this long i didnt mind . car is running better than ever .

now i have a wheel hub bearing in the rear that sounds nasty . do these go often ?

also my car has around 70k and my spark plugs have not yet been changed , what does subaru charge for this ? thankyou all
03wrx84 is offline  
#36 Old 06-14-2009, 09:00 PM
WRXtuners Member
 
03 CrazyTaxi's Avatar
 
Join Date: Jan 2006
Location: Missouri
Posts: 728
Images: 4
03 CrazyTaxi is known to be trustworthy and helpful 03 CrazyTaxi is known to be trustworthy and helpful
Send a message via MSN to 03 CrazyTaxi Send a message via Yahoo to 03 CrazyTaxi
Yes Subaru will charge for this but you can do it yourself for MUCH cheaper.

You'll need a 10mm, 12mm, and 5/8" spark plug sockets, various length extentions, a 10mm box wrench, a spark plug gap tool and a flat head screwdriver. Pull the battery, washer fluid tank (just put it on the shock tower without unhooking the fluid line), and the air filter housing. Work on ONE plug at a time. Pull the coil pack off using a 12mm socket. Using the spark plug socket and a short extension, pull the old plug. Gap the new plug to .028 and install the new plug. Be careful you don't cross thread it or you'll have to pull the motor and helicoil everything... Put the coil pack back on and tighten it down. Repeat on all cylinders, reinstall the filter housing, washer fluid tank, and battery.

VF34'd Corvette Killer aka Doug
03 CrazyTaxi is offline  
#37 Old 06-16-2009, 06:36 PM
WRXtuners Member
 
Join Date: May 2009
Location: Pennsylvania
Posts: 19
03wrx84 is an unknown
thanks crazytaxi , most helpful . what about the wheel bearings ?
03wrx84 is offline  
#38 Old 06-16-2009, 08:43 PM
WRXtuners Member
 
03 CrazyTaxi's Avatar
 
Join Date: Jan 2006
Location: Missouri
Posts: 728
Images: 4
03 CrazyTaxi is known to be trustworthy and helpful 03 CrazyTaxi is known to be trustworthy and helpful
Send a message via MSN to 03 CrazyTaxi Send a message via Yahoo to 03 CrazyTaxi
Unless you have a hydraulic press, you'll have to take that into a shop. I replaced mine at around 106k miles.

VF34'd Corvette Killer aka Doug
03 CrazyTaxi is offline  
#39 Old 08-16-2009, 04:49 PM
WRXtuners Member
 
yelljack's Avatar
 
Join Date: Jun 2003
Location: Europe
Posts: 181
Images: 9
yelljack is more helpful than not
I am getting the same code. I'll list all the facts. Parts list: TBE (catless, shh don't tell the state), walbro 255 lph, xs power tmic, 11.5lb flywheel, exedy street disc clutch, K&N typhoon CAI, GFB hybrid BOV set to 50/50, Cobb AP Stage 2 maps. Now I know everybody's first thoughts are, get rid of the CAI and get a custom/ pro tune. However, I've been running this setup for over a year, the CAI even longer (used a unichip b4 the cobb), without any problems. One day for shits and giggles I decided to reconfigure the typhoon as a SRI, boom P0171. Here is the list of things I have done to trouble shoot, some of them didn't make sense to me but I took peoples advice and did it anyways:
changed the oil
cleaned the MAF
changed the fuel filter (engine compartment one)
tried to clean the oil feeder line filter, car didn't have one ( pulled the bolt out of the line..no filter)
cleaned my k&n filter
went back to stock intake with the k&n drop in
........................ so there it is and remember, I was running that setup for a long time, problem free.
next thing I'll do is the carb spray and if I have to, the in tank fuel filter.
So, any Ideas???

forgot, blitz dual turbo timer
and, after everything I've done to trouble shoot I reset the ECU via the AP
also, I have been using the AP to monitor A/F ratio, it stays in the 14s under acceleration and the CEL only seems to come on when I am not accelerating. if I am driving it like I stole it the light doesn't come on, it is when I am cruising at a constant speed, yjay is when it always comes on.

Last edited by yelljack; 08-16-2009 at 05:26 PM. Reason: More facts
yelljack is offline  
#40 Old 08-16-2009, 05:28 PM
WRXtuners Member
 
baller_v24's Avatar
 
Join Date: Oct 2006
Location: Texas
Posts: 1,469
baller_v24 is known to be trustworthy and helpful baller_v24 is known to be trustworthy and helpful
Send a message via Yahoo to baller_v24
P0171 CEL Thread - Everything you ever wanted to know? - NASIOC

Read the "first disclaimer" on the link.

It happened because you reconfigured the typhoon CAI to a SRI. Either change it back to how it was or get a professional tune.

P0171= Fuel trim malfunction (A/F too lean)

rollin on 17's now and they're dirty
baller_v24 is offline  
#41 Old 08-16-2009, 10:48 PM
WRXtuners Member
 
03 CrazyTaxi's Avatar
 
Join Date: Jan 2006
Location: Missouri
Posts: 728
Images: 4
03 CrazyTaxi is known to be trustworthy and helpful 03 CrazyTaxi is known to be trustworthy and helpful
Send a message via MSN to 03 CrazyTaxi Send a message via Yahoo to 03 CrazyTaxi
Quote:
Originally Posted by baller_v24 View Post
It happened because you reconfigured the typhoon CAI to a SRI. Either change it back to how it was or get a professional tune.
Exactly the problem. Any intake change can mess with the MAF causing either a lean or rich code.

VF34'd Corvette Killer aka Doug
03 CrazyTaxi is offline  
#42 Old 08-18-2009, 01:33 PM
WRXtuners Member
 
yelljack's Avatar
 
Join Date: Jun 2003
Location: Europe
Posts: 181
Images: 9
yelljack is more helpful than not
As stated above I have done all that. The carb spray rendered no results. And, changed the front O2. I am just getting ready to say f%^k it and deal with the light.... the Cobb AP says I'm not actually running lean, and I go back to Iraq in a month. I plan on upgrading the turbo upon return in which case I'll buy the intakes reccomended by Cobb.

Last edited by yelljack; 08-18-2009 at 01:37 PM. Reason: cause
yelljack is offline  
#43 Old 08-18-2009, 02:06 PM
WRXtuners Member
 
baller_v24's Avatar
 
Join Date: Oct 2006
Location: Texas
Posts: 1,469
baller_v24 is known to be trustworthy and helpful baller_v24 is known to be trustworthy and helpful
Send a message via Yahoo to baller_v24
Did you reconfigure it back to CAI? If so a simple custom tune is cure to all.

Good luck in iraq.

rollin on 17's now and they're dirty
baller_v24 is offline  
#44 Old 08-18-2009, 07:22 PM
WRXtuners Member
 
man show's Avatar
 
Join Date: Apr 2007
Location: Maryland
Posts: 3,100
Images: 2
man show is a WRX expert worth listening to man show is a WRX expert worth listening to man show is a WRX expert worth listening to
20 bucks says Cobb recommends Cobb's intake

John
07 WRX (Albins 5MT + Blouch 20G)
Jorge Carrillo Tuned (365 whp/340 wtq)
man show is offline  
#45 Old 08-19-2009, 01:19 PM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
Cobbs stage one and two notes say stock intake or panel filter last I looked at them.

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On