02wrx check engine light problem - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 08-27-2008, 02:53 AM
WRXtuners Member
 
Join Date: Aug 2008
Location: Maine
Posts: 2
WRXTHOR is an unknown
02wrx check engine light problem

My check engine light always turns on because I have a High Flow catalytic converter on it. Does any body know a way to turn it off for a good one mechanic said he could replace a o2 sensor with a circuit so it would not read the emission error for like $186. HELP ????????

Last edited by mosc; 08-27-2008 at 09:22 PM.
WRXTHOR is offline  
Sponsored Links
Advertisement
 
#2 Old 08-27-2008, 02:28 PM
WRXtuners Member
 
Imprezd02's Avatar
 
Join Date: Nov 2006
Location: Florida
Posts: 67
Images: 5
Imprezd02 is an unknown
Send a message via AIM to Imprezd02
Dont pay $186 for a cel fix, please.

Go to autozone and pick up a spark plug anti fouler
drill a 1/2" hole in the tip
Screw your 02 sensor into the anti fouler
Then screw the anti fouler into the exhaust.

No more cel
Imprezd02 is offline  
#3 Old 08-27-2008, 07:35 PM
WRXtuners Member
 
Join Date: Aug 2008
Location: California
Posts: 9
Khooper is an unknown
The fault code for the catalytic converter may be caused by a Mass Airflow Sensor that is out of range. Replacing it will fix your problem.
_________________________
Autopartswarehouse Addict!
Khooper is offline  
#4 Old 08-27-2008, 09:23 PM
Moderator
 
mosc's Avatar
 
Join Date: Mar 2005
Location: Pennsylvania
Posts: 6,473
Images: 7
mosc is a helpful contributing member
Garage
Let me get this straight. You decided to make this thread twice and NEITHER go in the forum they belong? LOL. Fixed btw...

-mosc

04 STi 16G powered lagless fun
04 WRX: SOLD
mosc is offline  
#5 Old 08-30-2008, 02:28 PM
WRXtuners Member
 
Join Date: Aug 2008
Location: Maine
Posts: 2
WRXTHOR is an unknown
Thank you sorry I did not mean to enter twice it was some sort of glitch
WRXTHOR is offline  
#6 Old 08-30-2008, 07:18 PM
WRXtuners Member
 
Join Date: Jun 2008
Location: California
Posts: 13
Images: 9
lyndzy71 is an unknown
just unplug the positive side of the battery for like two min... then plug it back in and see if that works!

I did when mine would keep coming on and know its back to normal.
lyndzy71 is offline  
#7 Old 09-30-2008, 04:41 PM
WRXtuners Member
 
Join Date: Jun 2008
Location: New York
Posts: 144
blk02wrx is an unknown
Send a message via AIM to blk02wrx
do the spark plug defouler and unplugg the battery for a bit and hit the brakes a couple times. hooked the battey back up and it shouldn't come back on. and it will cost you about $4

O2 PEARL BLACK WAGON with some modds
blk02wrx is offline  
#8 Old 09-30-2008, 04:59 PM
WRXtuners Member
 
isd_intrepid's Avatar
 
Join Date: Jun 2007
Location: Montana
Posts: 134
isd_intrepid is an unknown
Send a message via Yahoo to isd_intrepid
Do It!!!!!!!!!
Do It Now!!!!!!!!!!
isd_intrepid is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On