02 Wrx Rough Idle/ Stalling after fmic install - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 05-30-2011, 07:57 PM
WRXtuners Member
 
Join Date: May 2011
Location: Pennsylvania
Posts: 11
Sbru02 is an unknown
02 Wrx Rough Idle/ Stalling after fmic install

I own a 2002 Subaru Wrx. Recently I installed a Turbo XS Fmic, and now I have a rough idle and when the idle does level out it runs smoothly for 1-4 mins before stalling out. I have hooked up to a scan tool to the car, and it shows a code that the vechile is running lean. I have a Walbro 255 fuel pump on the way. My question is, will the fuel pump be enough to resolve the issue, or will Sti pink injectors and a tune be needed to correct this problem. Other mods on the car are a apexi cat back exhaust system, Blitz turbo timer, Turbo XS boost controller, and AEM intake.
Sbru02 is offline  
Sponsored Links
Advertisement
 
#2 Old 05-30-2011, 08:09 PM
WRXtuners Member
 
Join Date: Sep 2009
Location: Michigan
Posts: 2,158
RcrsWetDream is known to be trustworthy and helpful RcrsWetDream is known to be trustworthy and helpful
You have a vacuum leak, check all your connections.

-Chris
RcrsWetDream is offline  
#3 Old 05-30-2011, 09:30 PM
WRXtuners Member
 
Join Date: May 2011
Location: Pennsylvania
Posts: 11
Sbru02 is an unknown
Thanks man I did check the connections at the time of the install, but there could be a good chance I missed something. I will def go back and check them over.
Sbru02 is offline  
#4 Old 05-30-2011, 10:03 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,371
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
Good luck

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
#5 Old 05-31-2011, 12:28 AM
WRXtuners Member
 
Join Date: Sep 2009
Location: Michigan
Posts: 2,158
RcrsWetDream is known to be trustworthy and helpful RcrsWetDream is known to be trustworthy and helpful
If the car is stumbling and stalling, it's pretty significant that you can probably spray some maf cleaner or starter fluid around the joints and it will raise the idle up once it gets sucked into the piping.

That's how I found the big leak I had which caused my idle to stumble and run 19:1 or higher lean at idle.

-Chris
RcrsWetDream is offline  
#6 Old 05-31-2011, 01:13 AM
WRXtuners Member
 
Join Date: May 2006
Location: Virginia
Posts: 2,332
Images: 9
brfatal is a WRX expert worth listening to brfatal is a WRX expert worth listening to brfatal is a WRX expert worth listening to
Garage
Ya, definitely a leak. That being said, that's a TERRIBLE mod for your setup. That intercooler will do more harm to you performance than anything with what you've got. Even with a larger turbo it's a bad investment (IMHO nothing 99% of people will ever do a on a stock block 2.0L will warrant a FMIC). You're running an intercooler designed for +/- 50 lb/min turbos running high boost.
brfatal is offline  
#7 Old 05-31-2011, 10:35 AM
WRXtuners Member
 
Join Date: May 2011
Location: Pennsylvania
Posts: 11
Sbru02 is an unknown
Thanks for all the suggestions. I will check all the connections out tonight, with some starter fluid, and retighten any connections that may need it. Will post how it turns out.
Sbru02 is offline  
#8 Old 05-31-2011, 04:29 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,371
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
Your not that far away from me man. But, I can't help with TurboXS boost controller set-up. I hope you figure it out.

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
#9 Old 05-31-2011, 04:51 PM
WRXtuners Member
 
Join Date: May 2011
Location: Pennsylvania
Posts: 11
Sbru02 is an unknown
Yeah I see your close. Its cool, I don't usually run the car with boost controller on. The guy who had it before me had it installed.
Sbru02 is offline  
#10 Old 05-31-2011, 07:34 PM
WRXtuners Member
 
Join Date: May 2011
Location: Pennsylvania
Posts: 11
Sbru02 is an unknown
Well some conectors were loose. Tightened them, still ran kinda off, so messed around with my afc, n bumped the fuel up it seems to have worked, the missing is gone and no more stalling out.
Sbru02 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On