02 sensor question - Subaru WRX Forum
 1Likes
  • 1 Post By arcticscythe
 
LinkBack Thread Tools Display Modes
#1 Old 06-24-2014, 11:18 AM
WRXtuners Member
 
Join Date: May 2014
Posts: 13
jeddy is an unknown
02 sensor question

okay so i bought a 02 sensor and without double checking myself before i bought it,the sensor is for 05-09 2.0L, after comparing the only difference that i can tell is that the connector has a different pattern, 4 pins and colors are the same. if i just swap connectors, is the sensor compatible?
jeddy is offline  
Sponsored Links
Advertisement
 
#2 Old 06-24-2014, 11:46 AM
Premium Member
 
boo-key bear's Avatar
 
Join Date: Dec 2008
Location: Tennessee
Posts: 1,164
Images: 6
boo-key bear is known to be trustworthy and helpful boo-key bear is known to be trustworthy and helpful
Garage
Front or rear? Probably should trade it for the right one anyway.

Sent from AutoGuide.com Free App

Adair
06' wrx tr
Phatbotti tuned!
boo-key bear is online now  
#3 Old 06-24-2014, 12:47 PM
WRXtuners Member
 
Join Date: May 2014
Posts: 13
jeddy is an unknown
its the sensor in the up pipe right before the turbo
jeddy is offline  
#4 Old 06-24-2014, 02:24 PM
WRXtuners Member
 
arcticscythe's Avatar
 
Join Date: Dec 2013
Location: California
Posts: 380
arcticscythe is known to be trustworthy and helpful arcticscythe is known to be trustworthy and helpful
Pretty good chance its the same but honestly its not worth the headache down the road when its not "exactly" the same. Its worth the drive back to swap it for the right one.
Epictofer likes this.

Jason
13 WRX Hatch
arcticscythe is offline  
#5 Old 06-24-2014, 04:06 PM
Premium Member
 
boo-key bear's Avatar
 
Join Date: Dec 2008
Location: Tennessee
Posts: 1,164
Images: 6
boo-key bear is known to be trustworthy and helpful boo-key bear is known to be trustworthy and helpful
Garage
As I stated in another thread, this one needs to be replaced with a oem replacement. I've replaced this one before with one from a parts store that didn't clear the cel but once replaced with oem everything was fine.

Sent from AutoGuide.com Free App

Adair
06' wrx tr
Phatbotti tuned!
boo-key bear is online now  
#6 Old 06-29-2014, 06:42 AM
WRXtuners Member
 
Join Date: Oct 2013
Location: Vermont
Posts: 2
dustminer is an unknown
if its in the up pipe its most likely the egt sensor !
dustminer is offline  
#7 Old 07-03-2014, 11:54 AM
WRXtuners Member
 
Join Date: May 2014
Posts: 13
jeddy is an unknown
the problem was i bought it on ebay so i figured i go ahead and try to use it. i cut and rewired the sensor(crimped and heat shrink) with the old sensor connector, its working alright so far. and it is the front a/f sensor, egt sensor is just downstream right befor the turbo. thanks for the advice guys
jeddy is offline  
#8 Old 07-03-2014, 12:33 PM
WRXtuners Member
 
arcticscythe's Avatar
 
Join Date: Dec 2013
Location: California
Posts: 380
arcticscythe is known to be trustworthy and helpful arcticscythe is known to be trustworthy and helpful
Jeddy,

Glad to hear its working, You might want to wrap that heat shrink with a thermal protectant. Most of my soldiering heatshrink is only good up until about 150 celcuis. Most of the time under hood temps are well below 150 but on hot days on the 405 freeway ive seen temps up to 220 at the intake end. It might be worth wrapping in some of that foil tape just to be safe.
arcticscythe is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On