GO4IT Racing school and Flatirons Tuning - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 06-03-2007, 11:35 AM Thread Starter
WRXtuners Member
 
nick4592's Avatar
 
Join Date: Sep 2005
Location: Colorado
Posts: 1,030
Images: 9
nick4592 is more helpful than not
Send a message via AIM to nick4592 Send a message via MSN to nick4592 Send a message via Yahoo to nick4592
GO4IT Racing school and Flatirons Tuning

GO4IT Racing School and Flatirons Subaru put this track day on for us...about 60 Subby's and a real good time...learned a lot and had a blast

Hopefully more pictures will come up

http://s133.photobucket.com/albums/q...ediafilter=all

ME


The Picture Thread
http://www.awdpirates.net/phpBB2/vie...=442268#442268

The Original Thread
http://www.awdpirates.net/phpBB2/vie...035&highlight=

"Life's a bowl of punch so go ahead and Spike it!" -311
nick4592 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 06-03-2007, 11:48 PM
WRXtuners Member
 
baller_v24's Avatar
 
Join Date: Oct 2006
Location: Texas
Posts: 1,469
baller_v24 is known to be trustworthy and helpful baller_v24 is known to be trustworthy and helpful
Send a message via Yahoo to baller_v24
that looks like alot of fun. im definately gonna try some road racing when i get back to the states. love the scenery too,

rollin on 17's now and they're dirty
baller_v24 is offline  
post #3 of 8 Old 06-04-2007, 04:27 PM
WRXtuners Member
 
chevarian113's Avatar
 
Join Date: Feb 2007
Location: Colorado
Posts: 170
Images: 1
chevarian113 is an unknown
Send a message via AIM to chevarian113
I've got to add my thread to this... There are a bunch of pics inside with some video. It wa a great event and lots of fun. Nice to meet a few pirates as well! (awdpirates.net)

Nick, did you get that clamp replaced that day to drive more, or did you leave early?

http://www.wrxtuners.com/forums/show...039#post156039
chevarian113 is offline  
post #4 of 8 Old 06-04-2007, 05:29 PM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
As always, nice pics man
newtothegame is offline  
post #5 of 8 Old 06-04-2007, 08:26 PM Thread Starter
WRXtuners Member
 
nick4592's Avatar
 
Join Date: Sep 2005
Location: Colorado
Posts: 1,030
Images: 9
nick4592 is more helpful than not
Send a message via AIM to nick4592 Send a message via MSN to nick4592 Send a message via Yahoo to nick4592
Quote:
Originally Posted by chevarian113 View Post
Nick, did you get that clamp replaced that day to drive more, or did you leave early?]
Yeah I took a clap off my Inlet and turned it into a clap for my FMIC

I didn't get below 5K the whole 20min....my coolant was boiling....Damn that was fun

"Life's a bowl of punch so go ahead and Spike it!" -311
nick4592 is offline  
post #6 of 8 Old 06-04-2007, 10:28 PM
WRXtuners Member
 
Join Date: Sep 2006
Location: Nevada
Posts: 2,245
WRXKidid775 is more helpful than not
i hate all of you.
haha man looks like good times. i always go and chill at the track but i cant drive since im not 18 o well though.

nick was your engine temp way up with your coolant like that or not too much?

Robby
02 rex is gone.
I defected to an evo :)
Evo is gone :(
Now I got nothing.
WRXKidid775 is offline  
post #7 of 8 Old 06-04-2007, 11:00 PM Thread Starter
WRXtuners Member
 
nick4592's Avatar
 
Join Date: Sep 2005
Location: Colorado
Posts: 1,030
Images: 9
nick4592 is more helpful than not
Send a message via AIM to nick4592 Send a message via MSN to nick4592 Send a message via Yahoo to nick4592
Yeah...the main reason my coolant was so hot is because the reservoir cap popped open and dropped the pressure in the lines...luckily it was on the last two laps so no harm was really done

"Life's a bowl of punch so go ahead and Spike it!" -311
nick4592 is offline  
post #8 of 8 Old 06-05-2007, 03:18 PM
WRXtuners Member
 
chevarian113's Avatar
 
Join Date: Feb 2007
Location: Colorado
Posts: 170
Images: 1
chevarian113 is an unknown
Send a message via AIM to chevarian113
Nice... Yeah, I was running really high RPM's as well, car did great though. i dont have any guages, but it seemed fine when i got back in to the pit. My engine temp never went up. I wasnt running nearly as hard as some of the guys out there.
chevarian113 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On