UTEC-not getting power at high RPM - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 11-26-2007, 03:29 PM Thread Starter
WRXtuners Member
 
WVWRX's Avatar
 
Join Date: Oct 2006
Location: Michigan
Posts: 12
WVWRX is an unknown
Send a message via Yahoo to WVWRX
UTEC-not getting power at high RPM

Just got my LM-1 Wideband and started tuning. Great fun and good results.

Hopefully, I'm not

I've hit a bit of a roadblock in the 4500-5000 RPM and 80-90% MAP on fuel. I keep trying remove fuel as my AFRs are still in the low 10s and 9s, but it doesn't seem to help. This also translates into a flat spot in the power.

I'm going small steps to avoid any nasty side effects. Just to confirm, more negative should make the MAF voltage more negative and thus fool the ECU into giving less fuel, right? Then the AFR should rise (more air, less fuel, higher AFR).

The other thing I noticed is that my injector duty cycle hits 100% in that area, so the ECU can't add any more fuel. But since I'm trying to remove fuel, I figured this is not a problem (yet). I do have pink STi injectors in hand, but haven't installed them.

So my real question: Should I keep trying remove fuel or should I be looking to move up the the pink injectors?

Map and Log Map are attached.

TIA for any responses.

Quick overview of mods:

Installed:
- AEM Cold Intake
- TurboXS TMIC
- Unorthodox Racing Drive Pulley
- TurboXS Turboback w/Muffler
- Headers w/ Integral Catless Uppipe
- TurboXS UTEC
- LM1 Wideband AFR

On deck, but not installed:
- STi pink injectors
Attached Files
File Type: txt 20071120-Rev27.txt (12.0 KB, 80 views)
File Type: zip LogMap-Rev27.zip (3.3 KB, 59 views)

-Karl
Muskegon, MI
'02 WRX
WVWRX is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 11-26-2007, 05:51 PM
WRXtuners Member
 
SWFL Scooby's Avatar
 
Join Date: Jun 2007
Location: Florida
Posts: 232
Images: 5
SWFL Scooby is an unknown
If the injector duty cycle is hitting 100%, change the injectors. And be careful backing off fuel, dangerous territory if you aren't a very experienced tuner.

D-Rock
Under constant pressure
SWFL Scooby is offline  
post #3 of 3 Old 11-28-2007, 08:05 PM Thread Starter
WRXtuners Member
 
WVWRX's Avatar
 
Join Date: Oct 2006
Location: Michigan
Posts: 12
WVWRX is an unknown
Send a message via Yahoo to WVWRX
Quote:
Originally Posted by SWFL Scooby View Post
If the injector duty cycle is hitting 100%, change the injectors. And be careful backing off fuel, dangerous territory if you aren't a very experienced tuner.
I understand your concern, but my AFRs are still in the 9s and low 10s based on the LM-1. Using Mick the Ginge's Guide (http://www.spryracing.com/FAQS/techn...2004-notes.pdf) , I have been shooting for 11-11.5 AFR, so I think I'm still in pretty safe area. I have a EGT sensor on order to make sure I'm still in the safe area.

I can't quite get past the correlation between AFR and power. If I put in pink injectors and add more fuel, it seems like I would be losing power. Maybe I'm not seeing the forest for the trees. Can't find out unless I try the injectors, I suppose.

Thanks for the input.

-Karl
Muskegon, MI
'02 WRX
WVWRX is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome