Coolant leak?! Had for months! - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 03-04-2014, 11:15 AM
WRXtuners Member
 
Join Date: Mar 2014
Posts: 40
justin93m is an unknown
Coolant leak?! Had for months!

new to this forum, but i have an 03 wrx engine and transmission have both been replaced, did not replace thermostat or water pump. i have a coolant leak but only when the car starts and is cold, but once it gets to normal temp there is no more leak. brand new headgaskets from cometic put on 3 months ago. water pump? bad Rad? the resivoir will drain but the car wont overheat till its empty, oil is fine and no smoke or anything? HELP PLEASE!!!

Any ideas please!
justin93m is offline  
Sponsored Links
Advertisement
 
#2 Old 03-04-2014, 11:22 AM
WRXtuners Member
 
06_hawk_eye's Avatar
 
Join Date: Nov 2012
Location: Pennsylvania
Posts: 699
06_hawk_eye is an unknown
Pressure test?


Sent from AutoGuide.com App
06_hawk_eye is offline  
#3 Old 03-04-2014, 11:26 AM
WRXtuners Member
 
Join Date: Mar 2014
Posts: 40
justin93m is an unknown
tested it and it held pressure and no leak, but it might have been warm when they did it
justin93m is offline  
#4 Old 03-04-2014, 12:08 PM
WRXtuners Member
 
Join Date: Mar 2014
Posts: 40
justin93m is an unknown
any other suggestions, i took it to the dealership and they didnt even know what was wrong. just once the car starts it leaks then will get to normal temp and not leak, a gasket? but which one?
justin93m is offline  
#5 Old 03-04-2014, 01:07 PM
WRXtuners Member
 
Join Date: Aug 2013
Location: North Carolina
Posts: 55
Epictofer is an unknown
possible water pump seal- when the shaft is turning it could cause it to leak. that could be why its doing it only when its running. seen it happen on an audi once. other wise pressure test with it running, if that doesn't find it then drive it till it gets worse? no don't do that.
Epictofer is offline  
#6 Old 03-04-2014, 01:31 PM
WRXtuners Member
 
Join Date: Mar 2014
Posts: 40
justin93m is an unknown
yea, once i start the car it will leak, but when car reaches normal temp it wont leak again till the car gets cold and starts again.
justin93m is offline  
#7 Old 03-05-2014, 09:51 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
you HAVE to be able to see where it's leaking from.

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#8 Old 03-05-2014, 10:05 AM
WRXtuners Member
 
Join Date: Mar 2014
Posts: 40
justin93m is an unknown
its coming from the area around th bottom rad hose.
justin93m is offline  
#9 Old 03-06-2014, 06:43 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
replace the hose or at least take it off and chk for cracks. Might be something simple.

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#10 Old 03-06-2014, 08:28 AM
WRXtuners Member
 
Join Date: Mar 2014
Posts: 40
justin93m is an unknown
okay thank you!
justin93m is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On