Blown Turbo? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 05-01-2011, 09:04 PM Thread Starter
WRXtuners Member
 
EducateMe's Avatar
 
Join Date: May 2011
Location: Maine
Posts: 5
EducateMe is an unknown
Blown Turbo?

My turbo doesnt kick in at any point, it sounds to be struggling & instead of a whistling it makes a scratching noise (metal on metal sound). Someone said i may have seized the main bearing? Blue smoke billows out of the tail pipe. I parked the car and havent drove it since. But i had to drive it home once the noise started. It got worse and worse and eventually stopped. But the turbo seemed to be gone entirely. The check engine light and "traction control light" stay on along with a flashing of the cruise control light. Everything is under factory warantee so im not worried. Just want some answers.

Thanks
EducateMe is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-01-2011, 10:29 PM
 
wagonracer's Avatar
 
Join Date: Jul 2006
Location: Connecticut
Posts: 1,301
Images: 9
wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to
You have replies to your earlier post on the same subject
wagonracer is online now  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On