Update on 17000 mile clutch slipage - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 01-18-2005, 03:53 PM
WRXtuners Member
 
Rain_Racer's Avatar
 
Join Date: Jul 2004
Location: Texas
Posts: 453
Rain_Racer is an unknown
Update on 17000 mile clutch slipage

My clutch started slipping at like 17,500 miles and I resolved to take it in for warrenty repair the following weekend. So all week I treated her sooo gingerly and I didn't slip after the first day (got like 27 mpg too keeping my rpms so low)

well after the week was over I drove it to the shop on saturday. On the way I decided to make sure I could still reproduce the clutch slipping problem. I used to just have to gun it in 4th gear and the rpms would surge then the clutch would catch and I would be on my way.

OF COURSE
by the time I got to the shop I still had not reproduced the problem, it was no longer slipping. I have been driving like normal since then and it has not slipped once... What gives? was it cold weather? (it does not get colder than 20 degrees here in texas)

I imagine it will get bad again, but I would just like to get it nipped in the bud
Rain_Racer is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On