Subaru WRX Forum

Subaru WRX Forum (
-   Drivetrain & Tranny (
-   -   Transmission slipping (

cjtimothy92 12-10-2013 11:13 PM

Transmission slipping
This problem recently started to occur. Everytime I am racing the engine with the gas pedal to the floor the transmission seems to slip as soon as the turbo kicks in at 3.2 rpms. If I only engage the gas pedal half way or less the tranny works fine and never slips but only when the pedal is to the floor. Also I have a check engine light on for P1560 which reads a transmission issue. Is it possible to just be a faulty throttle position sensor or would I be needing a whole new tranny for my peak power to return?

[color=gray]Sent from [url=] Free App[/url][/color]

turmic 12-10-2013 11:25 PM

Sign up as a member and tell us your mods or we can't even tell you much to help out.

cjtimothy92 12-11-2013 07:58 AM

It's a stock 2003 Subaru impreza wrx with a stock turbo sport wagon

[color=gray]Sent from [url=] Free App[/url][/color]

brfatal 12-11-2013 11:06 AM

Auto or manual.

P1560 is not transmission related. It's an ECU voltage issue.

Haw1es 12-11-2013 11:42 AM

Sounds to me to be a clutch issue, but without knowing if its auto or manual that's a total shot in the dark.

All times are GMT -5. The time now is 08:38 AM.

Powered by vBulletin®. Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

For the best viewing experience please update your browser to Google Chrome