My car revs without the clutch in - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 09-22-2004, 12:51 AM Thread Starter
WRXtuners Member
 
Join Date: Mar 2003
Location: California
Posts: 50
Images: 8
meth311 is an unknown
Send a message via AIM to meth311
My car revs without the clutch in

Okay i had a leak in my up-pipe the flange was missing two nuts and the gasket was blown...so anyways i think i had my utec tuned with this leak. I got this problem fixed but now when i drive my car if i punch it in 3rd, 4th and esp 5th around 4 grand it revs to about 5500 (it happens at different rpms usally around this area though) the mph go up and when the speedo catches with the rpms it car continues on, but if i give it a lil gas it doesnt do this. Is cause of the utec or is my car just screwed?
meth311 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-04-2004, 01:18 AM
WRXtuners Member
 
SloRice's Avatar
 
Join Date: Apr 2003
Location: Ohio
Posts: 329
Images: 4
SloRice is an unknown
Send a message via AIM to SloRice
Just to clarify what you are saying.....In fourth gear, you punch it and the revs go up about a 1000-1500 rpm but the car doesn't really accelerate. But then the speed catches up to where the revs are at and the the mph and rpm continue at the normal rate.

If so......you need a new clutch.

happened to me in my WRX (after 70 passes at the dragstrip and 15 autox's).
SloRice is offline  
post #3 of 3 Old 10-05-2004, 05:40 AM Thread Starter
WRXtuners Member
 
Join Date: Mar 2003
Location: California
Posts: 50
Images: 8
meth311 is an unknown
Send a message via AIM to meth311
yeah i needed i a new clutch i am putting it on this wed. thanks
meth311 is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome