God dammit 5 speed - Subaru WRX Forum
 1Likes
  • 1 Post By Danny Contreras
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 04-15-2017, 02:48 PM Thread Starter
WRXtuners Member
 
Join Date: Jan 2017
Location: California
Posts: 10
Danny Contreras is an unknown
God dammit 5 speed

Hey its Danny here. So on tuesday I was driving around and noticed my grab/bite point of my clutch getting lower and lower. I quickly knew it was gonna be a long week ahead. Anyways, it got to the point where the clutch felt spongy or like nothing was grabbing on and gears wouldn't go in.... Checked the master cylinder and it seemed fine... Could it be the clutch? Help! I'm no mechanic ....
Danny Contreras is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 04-16-2017, 08:34 AM
WRXtuners Member
 
Join Date: Jul 2015
Location: New York
Posts: 233
RoboTuner is known to be trustworthy and helpful RoboTuner is known to be trustworthy and helpful
Mileage? Have you swapped brakes/fluid lately? Swapped the clutch? Could be a few things but we need more info. Slave cylinders go before a MC usually, and if you have a super HD clutch it will wear the system faster (internal seals). Try having a friend help you bleed the clutch system, that's the first step. It's a royal pain as the slave cyl is on top on the transmission.

Clutches don't usually go out like that, unless you launch the car like crap all the time and/or you just slip tf out of it.
RoboTuner is offline  
post #3 of 6 Old 04-16-2017, 03:54 PM Thread Starter
WRXtuners Member
 
Join Date: Jan 2017
Location: California
Posts: 10
Danny Contreras is an unknown
We bled it and it was fine it's at 85k miles and supposedly the mechanic from the dealer replaced the clutch already.
Danny Contreras is offline  
 
post #4 of 6 Old 04-18-2017, 08:39 AM
WRXtuners Member
 
Join Date: Jul 2015
Location: New York
Posts: 233
RoboTuner is known to be trustworthy and helpful RoboTuner is known to be trustworthy and helpful
Well if you bled the system properly and that didn't fix it you have about 3 options left. New MC, new SC, or a broken finger on the pressure plate. My 02 actually had 3-5 fingers fall off when I got stuck in 8" of loose sand and decided to quit all together after I was about a mile away driving on the road. NOTE, I had almost 200k on my MC/SC.

I'm guessing you're using the OEM clutch still? When it was working, did the RPMs rise in 5th but vehicle speed didn't go up like normal?

Have you been launching your car? lol
RoboTuner is offline  
post #5 of 6 Old 04-19-2017, 09:52 PM Thread Starter
WRXtuners Member
 
Join Date: Jan 2017
Location: California
Posts: 10
Danny Contreras is an unknown
The slave and master cylinders are fine. Me and my dad where taking off the tranny and my clutch fork is broken.... we haven't completely removed it but we're about to. As for oem clutch I believe it's using some performance clutch cause it's really heavy. And no I haven't launched my car, I know how bad these 5 speeds are lol
RoboTuner likes this.
Danny Contreras is offline  
post #6 of 6 Old 04-19-2017, 09:53 PM Thread Starter
WRXtuners Member
 
Join Date: Jan 2017
Location: California
Posts: 10
Danny Contreras is an unknown
Even then I wouldn't launch my car without launch control.... tried it once, bogged and stalled... never tried it again D:
Danny Contreras is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome