Clutch out at 17000 - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-08-2005, 02:50 PM Thread Starter
WRXtuners Member
 
Rain_Racer's Avatar
 
Join Date: Jul 2004
Location: Texas
Posts: 453
Rain_Racer is an unknown
Clutch out at 17000

ok so I am at 17,000 miles and my clutch is slipping. I have the super duper warrenty package and no mods.

While I did abuse my clutch a little (like 15 passes at the track total and very little street shenanigans)

I have smelled the burning clutch smell maybe a dozen times and I knew that if I kept using the car like I was that I would have to replace it early... but I figured more like 40,000 miles would be reasonable.

Anyway given the low miles on my car and the fact that I have the super plus gold warrenty, do you guys think I will have any trouble getting a new clutch for free?
Rain_Racer is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-08-2005, 06:33 PM
WRXtuners Member
 
WRXtreme's Avatar
 
Join Date: Mar 2003
Location: Pennsylvania
Posts: 1,654
WRXtreme is more helpful than not
Send a message via AIM to WRXtreme
While I am pretty sure the dealership will know that you have been abusing the clutch to get it to wear out at such a low milage I don't think they can do anything about it since you have no mods. I think that you might have to put up a little fight to get them to replace it.
WRXtreme is offline  
post #3 of 4 Old 01-08-2005, 11:09 PM
 
IBAUCLAPlaya's Avatar
 
Join Date: Oct 2003
Location: Ohio
Posts: 3,488
Images: 8
IBAUCLAPlaya is known to be trustworthy and helpful IBAUCLAPlaya is known to be trustworthy and helpful
Send a message via AIM to IBAUCLAPlaya
I think there is some sort of recall for clutches on the 04. I got mine replaced at 4k miles because I said it was squeaking. No more questions were asked lol.
IBAUCLAPlaya is offline  
post #4 of 4 Old 01-10-2005, 09:35 AM Thread Starter
WRXtuners Member
 
Rain_Racer's Avatar
 
Join Date: Jul 2004
Location: Texas
Posts: 453
Rain_Racer is an unknown
huh mine was squeaking, then it started slipping... I had a feeling I had not abused it THAT much
Rain_Racer is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome