clutch engagement issues - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 03-19-2010, 07:11 AM
WRXtuners Member
 
Join Date: Feb 2010
Location: Michigan
Posts: 4
ctgreddy is an unknown
clutch engagement issues

Just installed a new exedy oem clutch, and am having a few issues now. the trans will go into gear when not running, altho it doesn't go in too easily, but when it's running it wont go into gear, with the clutch fully depressed. I tried bleeding the clutch and when I did the whole pump slow, hold, crack bleeder, tighten bleeder, the clutch pedal would stay right on the floor and didn't come back at all. I'd pull it up and let it sit for a few minutes and then it would start to go in and out again, but still cant get it into gear. Any ideas? by doing some quick research I'm hoping maybe the tob just isn't "clicked in" all the way?
ctgreddy is offline  
Sponsored Links
Advertisement
 
#2 Old 03-19-2010, 07:37 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Get a PM out to Lil'shoaf on this.... He's gone through several clutches.

Paul
2007 XT
2007 MS3
pzr2874 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On