40 k miles, clutch problem when cold - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 01-08-2005, 04:59 PM Thread Starter
WRXtuners Member
 
Join Date: Dec 2004
Location: California
Posts: 17
vitesse is an unknown
40 k miles, clutch problem when cold

Ok, so I have a studdering problem when engaging off the clutch. It is not consistent and happens usually when the car is cold. Car has 40k miles, time for a new clutch?
vitesse is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-09-2005, 01:50 AM
WRXtuners Member
 
AZ-Scoob's Avatar
 
Join Date: Dec 2003
Location: Arizona
Posts: 264
AZ-Scoob is an unknown
Send a message via MSN to AZ-Scoob
there was a TSB through Subaru on shuddering clutches in the rex, pretty sure you are out warr on the problem. best bet is to get a new clutch as you suspected, that should take care of the problem

[I]"Winners never quit, quitters never win, those that never win or quit are idiots."[/I]
AZ-Scoob is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome