08 seems to smell like burning clutch allot - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 10-27-2008, 06:29 PM Thread Starter
WRXtuners Member
 
ratfink's Avatar
 
Join Date: Oct 2008
Location: Idaho
Posts: 518
ratfink is a helpful contributing member
08 seems to smell like burning clutch allot

This is my first new car, but not my first Suby. When I launch the car reasonably fast, or feather the clutch even a little it smells terrible. I was an ASE certified tech and I replaced allot of clutches. I never remember needing a break in period for full friction that made them smell so bad. I'm wondering if a test driver slipped the clutch terribly or maybe drove with the clutch partially disengage. Anyone have any thoughts?

Brad

AEM CAI, Perrin ELH wrapped, Catted Downpipe, Stage II XPT tune, K4RT30Y STS, lip, shark fin
ratfink is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 10-27-2008, 06:42 PM
Moderator
 
mosc's Avatar
 
Join Date: Mar 2005
Location: Pennsylvania
Posts: 6,499
Images: 7
mosc is a helpful contributing member
Garage
Could be engine smell too. Subaru's piping REAKS for a good 2500 miles if I remember right...

04 STi 16G powered lagless fun
04 WRX: SOLD
mosc is offline  
post #3 of 11 Old 10-27-2008, 06:50 PM Thread Starter
WRXtuners Member
 
ratfink's Avatar
 
Join Date: Oct 2008
Location: Idaho
Posts: 518
ratfink is a helpful contributing member
Never thought of that. It smelled bad (like hot paint/oil)the first day or two. This really smeels like clutch. The kinda smell I got out of my Toyota rockcrawler before I added a transfer case doubler. LOL

Brad

AEM CAI, Perrin ELH wrapped, Catted Downpipe, Stage II XPT tune, K4RT30Y STS, lip, shark fin
ratfink is offline  
post #4 of 11 Old 10-27-2008, 06:51 PM
Moderator
 
mosc's Avatar
 
Join Date: Mar 2005
Location: Pennsylvania
Posts: 6,499
Images: 7
mosc is a helpful contributing member
Garage
When my 04 (Had a WRX new, not the STi I have now) was new, I thought I was burning up the clutch like mad and that was the odor. It does smell a lot like clutch. If you're low on mileage, I'd tend to think it's actually engine odor and not clutch.

04 STi 16G powered lagless fun
04 WRX: SOLD
mosc is offline  
post #5 of 11 Old 10-27-2008, 07:42 PM Thread Starter
WRXtuners Member
 
ratfink's Avatar
 
Join Date: Oct 2008
Location: Idaho
Posts: 518
ratfink is a helpful contributing member
Is 250 miles low? LOL

So give it a couple thousand huh? I go in for an inspection @ 1000. I may ask about it if it's still as strong. It's odd it relates pretty directly to spirited take-offs.

Brad

AEM CAI, Perrin ELH wrapped, Catted Downpipe, Stage II XPT tune, K4RT30Y STS, lip, shark fin

Last edited by ratfink; 10-27-2008 at 11:15 PM.
ratfink is offline  
post #6 of 11 Old 10-27-2008, 11:13 PM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
My 07 (bought with 9 miles on it) reaked for weeks. It was the engine smell. After a day I popped the hood after a long drive. Worst idea ever, it smelled terrible right off the engine bay.

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
post #7 of 11 Old 03-24-2009, 11:42 AM
DGM
WRXtuners Member
 
DGM's Avatar
 
Join Date: Mar 2009
Location: Massachusetts
Posts: 2
DGM is an unknown
Hrm this is a relief to read, I been driving a stick since I got my license like 14 years ago, I've never burned out a clutch. I'm at about 700 miles now and anytime i get into first above 2k RPMs it smells like my clutch just melted.
DGM is offline  
post #8 of 11 Old 03-24-2009, 12:28 PM Thread Starter
WRXtuners Member
 
ratfink's Avatar
 
Join Date: Oct 2008
Location: Idaho
Posts: 518
ratfink is a helpful contributing member
We've got a little over 4000 now, and the smell is all but gone except for hard launches and my wife slipping the clutch. LOL

Brad

AEM CAI, Perrin ELH wrapped, Catted Downpipe, Stage II XPT tune, K4RT30Y STS, lip, shark fin
ratfink is offline  
post #9 of 11 Old 03-25-2009, 11:59 AM
WRXtuners Member
 
baller_v24's Avatar
 
Join Date: Oct 2006
Location: Texas
Posts: 1,469
baller_v24 is known to be trustworthy and helpful baller_v24 is known to be trustworthy and helpful
Send a message via Yahoo to baller_v24
i would say that's normal for hard launches and slipping the clutch.

rollin on 17's now and they're dirty
baller_v24 is offline  
post #10 of 11 Old 03-25-2009, 02:53 PM
DGM
WRXtuners Member
 
DGM's Avatar
 
Join Date: Mar 2009
Location: Massachusetts
Posts: 2
DGM is an unknown
Ya i'm not sure if i'm just not getting more used to the friction point or what but I'm about 1k miles, don't really think i'm doing anything different but no more smells

On a side note i need to stop driving so much or my 100k warranty is going to be done before 2010.

Last edited by DGM; 03-25-2009 at 08:13 PM.
DGM is offline  
post #11 of 11 Old 03-25-2009, 06:52 PM
WRXtuners Member
 
Join Date: Aug 2008
Location: Louisiana
Posts: 104
ajtoce is more helpful than not
Quote:
Originally Posted by DGM View Post
Ya i'm not sure if i'm just not getting more used to the friction point or what but I'm about 1k miles, don't really think i'm doing anything different but no more smells

On a side not i need to stop driving so much or my 100k warranty is going to be done before 2010.
dude, i just bought my car in august and my warranty is almost exactly1/3 done with 12,000 miles. 3yr/36,000 miles....haha ill be at 36,000 at one year at this rate.

God is love
ajtoce is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On