Im stage II!!.....sorta - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 06-04-2009, 07:06 PM Thread Starter
WRXtuners Member
 
srninjastar's Avatar
 
Join Date: Aug 2007
Location: Texas
Posts: 338
srninjastar is more helpful than not
Send a message via AIM to srninjastar
Im stage II!!.....sorta

just got a stage 2 tune from a buddy of mine who i thought was in san marcos. did logs and all that and he sent it to a friend of his who is gona tune the map properly for my car. problem is i dont have the stock airbox and have this aem cai. my car bucks alot when WOT but at higher rpms its fine. Second problem is i have an exhaust leak and its really annoying. And the final probelm is my 02 sensor was put in inccorectly by the person who had the car before me. the sensor is all stripped and wont fit in the threaded area on my DP.

i was so happy when i got my tune, now im pissed cause of all these stupid things that wont let me enjoy it. FML
srninjastar is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 06-05-2009, 12:58 AM
WRXtuners Member
 
baller_v24's Avatar
 
Join Date: Oct 2006
Location: Texas
Posts: 1,469
baller_v24 is known to be trustworthy and helpful baller_v24 is known to be trustworthy and helpful
Send a message via Yahoo to baller_v24
that sucks, u should really get them fixed to fully enjoy the upgrade.

rollin on 17's now and they're dirty
baller_v24 is offline  
post #3 of 7 Old 06-05-2009, 01:34 AM Thread Starter
WRXtuners Member
 
srninjastar's Avatar
 
Join Date: Aug 2007
Location: Texas
Posts: 338
srninjastar is more helpful than not
Send a message via AIM to srninjastar
so i got the stock airbox from a guy with an sti. put that in and it doesnt buck as much. turns out that my MAF is jacked up. so im gona get one on saturday along with fixing my exhaust. as for the o2 sensor i need to take it to a machine shop to get it re-threaded so it will fit, or ill just put a bolt in there for the time being until i can afford a new sensor
srninjastar is offline  
post #4 of 7 Old 06-05-2009, 06:50 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,980
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Ok, how is your MAF messed up ? Clean it first, save yourself 200.00 by trying a 5.00 can of cleaner.

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
post #5 of 7 Old 06-05-2009, 12:15 PM
WRXtuners Member
 
baller_v24's Avatar
 
Join Date: Oct 2006
Location: Texas
Posts: 1,469
baller_v24 is known to be trustworthy and helpful baller_v24 is known to be trustworthy and helpful
Send a message via Yahoo to baller_v24
+1 try to clean it first, see if that's the problem.

rollin on 17's now and they're dirty
baller_v24 is offline  
post #6 of 7 Old 06-05-2009, 02:41 PM Thread Starter
WRXtuners Member
 
srninjastar's Avatar
 
Join Date: Aug 2007
Location: Texas
Posts: 338
srninjastar is more helpful than not
Send a message via AIM to srninjastar
i didnt have any and i just thought about doing that so ima do that first before i buy a new one. but when i swaped a brand new maf from my friends wrx and put it in mine and ran it. good lord ive never felt so much low end power ever and not once did it buck. that stage II sure is something. i looove it
srninjastar is offline  
post #7 of 7 Old 06-05-2009, 06:47 PM Thread Starter
WRXtuners Member
 
srninjastar's Avatar
 
Join Date: Aug 2007
Location: Texas
Posts: 338
srninjastar is more helpful than not
Send a message via AIM to srninjastar
well i cleaned the balls out of my maf and let it dry for a while. put it back in and ran it. still bucks like a crazy horse. i cant go past 3k without it bucking.
srninjastar is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome