boost problem... - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 06-23-2009, 01:15 AM Thread Starter
WRXtuners Member
 
srninjastar's Avatar
 
Join Date: Aug 2007
Location: Texas
Posts: 338
srninjastar is more helpful than not
Send a message via AIM to srninjastar
boost problem...

a few weeks back i put on my 4" DP and had to remove the TMIC along with the bov to get to some hard to reach bolts. while i put it on and put everything back i accidently tore the bov paper gasket in half. i tired to put as much of as i could back on and i bolted it up and everything. now when i go WOT ill hear a leak and ill feel a light power loss but ill still maintain boost.

...idk what do you suba-gurus think i should do?
srninjastar is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 06-23-2009, 01:35 AM
WRXtuners Member
 
baller_v24's Avatar
 
Join Date: Oct 2006
Location: Texas
Posts: 1,469
baller_v24 is known to be trustworthy and helpful baller_v24 is known to be trustworthy and helpful
Send a message via Yahoo to baller_v24
Subaru 02-09 WRX & 04-09 STi bypass valve gaskets, JSC Speed 02-09 WRX & 04-09 STi Engine

Come on man, I know u know the answer.

rollin on 17's now and they're dirty
baller_v24 is offline  
post #3 of 10 Old 06-23-2009, 01:59 AM
WRXtuners Member
 
jed344's Avatar
 
Join Date: Feb 2009
Location: Iowa
Posts: 147
Images: 3
jed344 is an unknown
guy a new gasket and call it good lol
jed344 is offline  
post #4 of 10 Old 06-23-2009, 03:44 AM Thread Starter
WRXtuners Member
 
srninjastar's Avatar
 
Join Date: Aug 2007
Location: Texas
Posts: 338
srninjastar is more helpful than not
Send a message via AIM to srninjastar
well i went out on a bridge where its a mile long or so and went WOT. when i did the leak(or so i thought) sounded more like an EWG, but i dont have one. idk maybe im just getting paranoid. im not used to the sounds my car makes anymore with the 4" dp and an exhaust that still leaks i cant tell what is what. i havent herd my bpv in the longest time probably cause my turbo spools all the time and makes that constant hissss.

ima buy the bov paper gasket regardless.

baller ## right i know i know but i just wanted to get someones opinion first
srninjastar is offline  
post #5 of 10 Old 06-23-2009, 12:53 PM
WRXtuners Member
 
baller_v24's Avatar
 
Join Date: Oct 2006
Location: Texas
Posts: 1,469
baller_v24 is known to be trustworthy and helpful baller_v24 is known to be trustworthy and helpful
Send a message via Yahoo to baller_v24
Do you have an aftermarket uppipe gasket as well? Or is it the OEM style gasket on the uppipe to turbo gasket?

The reason why I ask is because if that gasket takes a dump it will sound like you have an EWG.

rollin on 17's now and they're dirty
baller_v24 is offline  
post #6 of 10 Old 06-23-2009, 01:54 PM
WRXtuners Member
 
04paulieWRX's Avatar
 
Join Date: Jan 2008
Location: New York
Posts: 233
04paulieWRX is an unknown
sounds like you may have somewhat botched your installation. buy new gaskets, including turbo to dp, which sounds like it went bad. make sure to buy subaru stock replacements as they are the best
04paulieWRX is offline  
post #7 of 10 Old 06-23-2009, 02:37 PM Thread Starter
WRXtuners Member
 
srninjastar's Avatar
 
Join Date: Aug 2007
Location: Texas
Posts: 338
srninjastar is more helpful than not
Send a message via AIM to srninjastar
i think thats what it is. ill buy both the bpv and dp gasket. and then chuck my old exhaust and get something else cause this doughnut flange crap is pissin me off. ill just buy the perrin dual tip cb. that is a full 3" with a flat flange i just hope its long enough cause the dp i have is kinda short and i have no clue why.
srninjastar is offline  
post #8 of 10 Old 06-24-2009, 01:37 AM Thread Starter
WRXtuners Member
 
srninjastar's Avatar
 
Join Date: Aug 2007
Location: Texas
Posts: 338
srninjastar is more helpful than not
Send a message via AIM to srninjastar
so i told my friend who tuned my car about all the crap thats going on, so he got his laptop and tuning softwear and we went on a few road pulls. turns out my max psi was 21.33 and after 4 1/2k it droped to 13 then 8. that was pretty messed up and makes sense cause i felt a loss in power as i went into the higher rpm's. so i got a retune so im back at 15psi and its more consistant throughout the power band but hes still gona send it to his tuner friend to mess around with it. in the mean time im going to my local subaru dealership and buy the gaskets then get a retune. hopefully all will be good once that is taken care of..
srninjastar is offline  
post #9 of 10 Old 06-24-2009, 11:07 AM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
Hey man, glad you are getting it sorted out. Hoep the gaskets solve most of your problems. Keep us updated.

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
post #10 of 10 Old 06-24-2009, 03:00 PM Thread Starter
WRXtuners Member
 
srninjastar's Avatar
 
Join Date: Aug 2007
Location: Texas
Posts: 338
srninjastar is more helpful than not
Send a message via AIM to srninjastar
so i got a call from my friend and according the logs and what not i have a boost leak somewhere. so im getting the bpv and dp gasket when i get off work. but yesterday i noticed under the hood the Y pipe to the turbo was kinda sliding off and the clamp was on sideways. so yeaa....ima get that fixed and see what happens.
srninjastar is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On