suspension update, HELP!!! - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 05-07-2009, 06:33 PM
WRXtuners Member
 
phatmike0704's Avatar
 
Join Date: May 2008
Location: Illinois
Posts: 147
phatmike0704 is an unknown
Send a message via AIM to phatmike0704 Send a message via Yahoo to phatmike0704
suspension update, HELP!!!

ok so i just put my OEM rear struts on today, 04 wrx. Everything was tightened, everything looked good. but i have the worst sounding clunk on my car. they feel like they're about to go through the top hat. at first i thought it was the fact that i bought 02-03 struts but i didnt, heres the site
AutoCenter.net i bought the top 2. then i also thought it could be the mount but they looked fine. then i realized that when i took the springs off, i didnt need the compressor to get it off. are the stock springs supposed to be that weak? my dad just squeezed them with his hands. could that be the problem?
phatmike0704 is offline  
Sponsored Links
Advertisement
 
#2 Old 05-07-2009, 09:04 PM
WRXtuners Member
 
Join Date: Oct 2007
Location: Texas
Posts: 59
tnot is an unknown
Quote:
Originally Posted by phatmike0704 View Post
ok so i just put my OEM rear struts on today, 04 wrx. Everything was tightened, everything looked good. but i have the worst sounding clunk on my car. they feel like they're about to go through the top hat. at first i thought it was the fact that i bought 02-03 struts but i didnt, heres the site
AutoCenter.net i bought the top 2. then i also thought it could be the mount but they looked fine. then i realized that when i took the springs off, i didnt need the compressor to get it off. are the stock springs supposed to be that weak? my dad just squeezed them with his hands. could that be the problem?


I really doubt if it's the springs. Check this how-to out, and reference step #29, which is where your problem might be:

"29. Reassemble, again fully tightening the 17mm nut. Note that the rear struts have a rubber bumper not just around the top of the spring (like the fronts) but also on the bottom spring perch that you will need to transfer to your new struts. Again note the orientation of the top perch and strut top mount like you did for the fronts."

03 WRX Wagon Spring and/or Strut Install - ClubWRX Forum - Subaru Impreza WRX and STi Community and Forums
tnot is offline  
#3 Old 05-07-2009, 09:57 PM
WRXtuners Member
 
jwtarbaj's Avatar
 
Join Date: Apr 2003
Location: Michigan
Posts: 1,344
Images: 11
jwtarbaj is more helpful than not
Send a message via AIM to jwtarbaj
Uhh if your Dad could compress the spring with his hands enough to remove the locknut he is either Superman or your springs are shot.

It sounds like you didn't torque down the locknuts on the top of the assembly(s). did you use a torque wrench to be sure you got them on there good and tight?
jwtarbaj is offline  
#4 Old 05-09-2009, 03:18 PM
WRXtuners Member
 
phatmike0704's Avatar
 
Join Date: May 2008
Location: Illinois
Posts: 147
phatmike0704 is an unknown
Send a message via AIM to phatmike0704 Send a message via Yahoo to phatmike0704
well just bought some megan racing springs. i wanna lower it anyway. i retightened everything and the clunk is still there, i guess im just gonna have to get new mounts. anyone know where i could get cheap oem ones. i found some at autocenter.net for $55 but i dont know if they come in a set of 2 or its just the single, anyone know?
phatmike0704 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On