Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Handling Tech (http://www.wrxtuners.com/forums/f53/)
-   -   My rebuilt Power Steering Pump died after 3 hours of driving. (http://www.wrxtuners.com/forums/f53/my-rebuilt-power-steering-pump-died-after-3-hours-driving-31247/)

MarkCruz 08-26-2011 08:21 PM

My rebuilt Power Steering Pump died after 3 hours of driving.
 
2004 WRX Wagon

My mechanic replaced my power steering pump, because it seized (...and busted the belts, causing my alternator not to work.) The new one quit working less than 2 hours after the repair. The fluid is full.

What is burning out my pumps?

Kjott21 08-27-2011 07:29 AM

[quote=MarkCruz;266672]2004 WRX Wagon

My mechanic replaced my power steering pump, because it seized (...and busted the belts, causing my alternator not to work.) The new one quit working less than 2 hours after the repair. The fluid is full.

What is burning out my pumps?[/quote]

Are you doing donuts or anything else that keeps you at full lock with the steering wheel?

MarkCruz 08-29-2011 04:59 AM

No I wasn't doing any abnormal driving. I got a second opinion from another mechanic, who claims thr first mechanic did nto clear the rack and pinion steering of old debris. He claims my entire steering system needs to be replaced along with a third pump.

turmic 08-29-2011 10:42 AM

Wow, that sucks. But, it makes sense if they rest of the rack is screwed up. Just make sure he can't flush the rack out first. Its a pain in the ass...but, seriously. Its a lot cheaper if you are willing to risk it that this mechanic can flush it all out clean.


All times are GMT -5. The time now is 07:34 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.