clicking?!?! - Subaru WRX Forum
LinkBack Thread Tools Display Modes
post #1 of 2 Old 05-31-2009, 03:24 PM Thread Starter
WRXtuners Member
phatmike0704's Avatar
Join Date: May 2008
Location: Illinois
Posts: 147
phatmike0704 is an unknown
Send a message via AIM to phatmike0704 Send a message via Yahoo to phatmike0704

just installed new rear oem struts in my 04 wrx last week. i been noticing that everytime i make a right turn or even turn it a little to the right, is starts clicking. and it clicks until the wheel is straight again, i didnt do alignment yet, could that be it?
phatmike0704 is offline  
Sponsored Links
post #2 of 2 Old 05-31-2009, 11:12 PM
WRXtuners Member
Join Date: Jun 2008
Location: New York
Posts: 144
blk02wrx is an unknown
Send a message via AIM to blk02wrx
i would check all the bolts and make sure you have everything tight and after thatmake sure the springs are on right and make sure you get that alignment.

O2 PEARL BLACK WAGON with some modds
blk02wrx is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome