Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Bolt-On Tech (EJ205 2.0L '02-05 WRX) (http://www.wrxtuners.com/forums/f52/)
-   -   Weird idle after deep water (http://www.wrxtuners.com/forums/f52/weird-idle-after-deep-water-32599/)

blazinbret 06-07-2012 03:14 PM

Weird idle after deep water
 
So it rained and flooded and was on way home from work and I hit a 2.5 foot puddle on accident and car started bugging down I dropped 2 and got out of it and lost my clutch for min like went all way to floor and barly worked after pumping and pumping it came back and is fine now.Now my car idles weird it goes from 2k to 1500 a few times then stops at 1500 and idles there. Its 02 Wrx and got aem intake and hks bov and full exhaust. It ran fine until that happened I sea foamed it and cleaned my mass and reset codes like 4 times now keeps happen. What would be cause for idle problem? Thanks

Sent from my LG-P925 using AutoGuide.com App

BLAZE2099 06-07-2012 07:47 PM

When did this happen? How long ago?
Water in exhaust.
Water in electrical.
2.5 feet could mean water in the intake.

bad grocerygetter 06-07-2012 09:14 PM

Could have shorted a sensor. What code(s) is it throwing if any?

blazinbret 06-08-2012 12:39 AM

Think it was sensor I cleaned all sensors on throttle body rest set computer and it fixed it self actually its running better then before. Thanks for the advise guys this is my first suby and and computer controlled car so still on learning curve.

Sent from my LG-P925 using AutoGuide.com App


All times are GMT -5. The time now is 10:33 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome