Wastegate/Turbo/Pill Question - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 06-09-2013, 06:08 PM
WRXtuners Member
 
Join Date: Jun 2013
Location: South Dakota
Posts: 17
cpeeler21 is an unknown
Wastegate/Turbo/Pill Question

I will start by saying this was a trial and error kind of thing. My boost was not moving past .5 and i read all the threads about the pill etc.. But really thought something did not look right in the picture below. it looks like somebody tried to put everything back to stock with the parts they had. The vacuum lines were crazy thin as you can see and the T was just sticking in the air. I finally found a picture of a stock setup which was def. not what mine looked like. mine had a larger tube going from turbo to the T and then a thin vacuum hose from the wastegate to the T and the the last line running to the controller. the picture i saw was a larger looking tube from the turbo to the split of the tee with the other end connecting to the T straight to the waste gate. So really i have a direct line to the turbo and waste gate which i did not before. I test drove it after I made this change and my goodness i had no idea. For a week i have only had the car to .5 and on wot it sounded terrible and i thought the turbo was going to blow up...The car holds between .7-1 with me being very cautious of throttle. The turbo spools up much quicker and i can hear it spool much better. Have not ran it hard. There is no pill also. Any thoughts from some experienced owners or maybe a picture of what their stock setup looks like. The car runs fine without the pill so far. Should i head to subaru and get the stock lines and pill? Thanks ahead of time!
Attached Images
 
cpeeler21 is offline  
Sponsored Links
Advertisement
 
#2 Old 06-09-2013, 06:10 PM
WRXtuners Member
 
Join Date: Jun 2013
Location: South Dakota
Posts: 17
cpeeler21 is an unknown
correction

It had the thin line going from the turbo to the T.
cpeeler21 is offline  
#3 Old 06-09-2013, 06:22 PM
WRXtuners Member
 
Join Date: Jun 2013
Location: South Dakota
Posts: 17
cpeeler21 is an unknown
The Fix

The fix
Attached Images
 
cpeeler21 is offline  
#4 Old 06-09-2013, 07:28 PM
WRXtuners Member
 
Brockton's Avatar
 
Join Date: Mar 2013
Location: Illinois
Posts: 372
Brockton is a helpful contributing member
Garage
The line diameter and pill are very important. I tried to replace my line with a slightly larger diameter hose, and it was letting just a tiny little bit of air around the pill, and I couldn't boost past 11psi on a 18 psi tune. Finally got the proper sized tube, put the pill in it (make sure its facing the right direction) and that fixed it. If you have the pill, just find the size of the hose diameter and find a replacement on line, dealer wanted 40 bucks for the hoses and pill, so I just bought a 5 dollar hose with the same diameter and saved 35 bucks.
Brockton is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On