VF39 Issues - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-18-2008, 04:33 AM Thread Starter
WRXtuners Member
 
dlh1999's Avatar
 
Join Date: Nov 2005
Location: Oregon
Posts: 304
Images: 9
dlh1999 is an unknown
VF39 Issues

Hi all,

Been a little while since I've posted here. Anyway, I recently tracked down a P&P VF39 for a great price. I got it in the mail yesterday and did a once-over to make sure all seemed to be in good shape. Unfortunately, a couple concerns kind of caught my attention, and I wanted to get some insight on them.

First, in checking for shaft play, it appears that the compressor wheel seems a bit 'sticky'; it spins, but when I try to make it spin on its own it just stops. Is this going to be a problem for functionality? I've always thought they are pretty free-spinning...

Second, I noticed this happened in the mail:



Sorry about the picture quality, but basically the tube got bent, which put a large crack right through it at the base. Obviously this needs to be fixed...is this something that can be reasonably fixed (drilled out & replaced, etc)?

Thanks for any and all feedback!
dlh1999 is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome