Turbo Whine - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 08-03-2005, 11:57 PM Thread Starter
WRXtuners Member
 
Join Date: Nov 2004
Location: Delaware
Posts: 6
stkblkwgn is an unknown
Question Turbo Whine

Recently installed my UTEC running stage 2 map on my wagon.

I had been getting readings up to 1.2 bar from my blitz DTT, which seemed to make little sense. The stock turbo setup should not be boosting that high.

After the UTEC install, the gauge would read up to 1.4, consistently in the mid 1.3 bar range. After boosting at this level for a day or so, I noticed a high pitched whine when coming on boost. I also found another boost gauge lying around the house and verified the readings.

I found a loose line from the UTEC boost controller (it was used and I guess it was loose) and zip tied it. Since then the readings have maxed out at 1.1 bar, but the high pitched noise has continued.

It only happens when I'm boosting more than 5 lbs.


I am wondering if there is any explanation or remedy other than turbo replacement. If I must replace the turbo, should I just buy a stocker off ebay for $100 or is it worth the money to get an STI turbo for $300? Is the 04 or 05 STI turbo an easy swap?

02 wagon
helix uppipe
helix downpipe
borla hush catback
turboxs utec

i was planning on doing a turbo swap about a year from now... i would not mind forking out the extra 200 bucks in the mean time if the STI turbo yielded another 15+ horses and or increased durability
stkblkwgn is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-04-2005, 10:04 PM
Vew
Moderator
 
Vew's Avatar
 
Join Date: Feb 2004
Location: West Virginia
Posts: 3,452
Images: 10
Vew is more helpful than not
Send a message via AIM to Vew
Try running the stock map and see what you're boosting. I dunno how accuracte those Blitz built in boost gauges are. You should be running around 1 bar with no EM and w/ TBE. If it shows it's 1 bar on stock map, you can use an allen key to turn down the boost if you need to for your Stage 2 map. It's not really a huge deal since the point of the UTEC is to correct AFR, timing, and boost and as long as you're not knocking.

Jon
"We live for a good time, not a long time."
RIP Colin McRae
Vew is offline  
post #3 of 5 Old 08-05-2005, 10:56 AM
WRXtuners Member
 
Join Date: Jun 2005
Location: Florida
Posts: 33
IslandSTI is an unknown
Normally when you have a bell mouth down pipe you will hear the turbo whine because the wastegate can breath better now but since you just up the boost you probably did not hear it before. I think the idea of going back to stock map is good because that will let you know if volume goes down when you lower the boost.

The more boost = the louder the whine.

If there is no change in volume then you might have a problem.
IslandSTI is offline  
post #4 of 5 Old 08-05-2005, 12:13 PM Thread Starter
WRXtuners Member
 
Join Date: Nov 2004
Location: Delaware
Posts: 6
stkblkwgn is an unknown
see thats the thing...

it was boosting atleast as high (1.12-1.18bar) before utec (with only uppipe and TBE) and I never heard the whining...

it was only after the UTEC was boosting it to 1.32-1.40bar that i noticed the whine

now i am running stage 2 (~1.10-1.6bar) max and the whine is very noticeble...

I'm going to try running the stock map, but I dont think it will make a difference since it starts whining well before hitting the eleveated boost levels.


oh and I also tried hooking up another gauge that was reading up to 20.5 psi quickly... consitently hitting 18 psi ( this was at the point when it was reading 1.4 bar)
stkblkwgn is offline  
post #5 of 5 Old 08-05-2005, 02:15 PM
Vew
Moderator
 
Vew's Avatar
 
Join Date: Feb 2004
Location: West Virginia
Posts: 3,452
Images: 10
Vew is more helpful than not
Send a message via AIM to Vew
I don't have a UTEC anymore and I still can hear my whine under acceleration in low RPM (below 3krpm)

Jon
"We live for a good time, not a long time."
RIP Colin McRae
Vew is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome