Is something missing?? - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 Old 09-30-2009, 11:57 AM
WRXtuners Member
 
gunk007's Avatar
 
Join Date: May 2008
Location: Minnesota
Posts: 265
Images: 5
gunk007 is more helpful than not
Is something missing??

So I took a pic of my engine compartment because it looks like something is missing. I have an 05. Is something supposed to be something in the upper left corner of the pic? If so, what? Thanks
Hopefully I uploaded the pic correctly.
Attached Images
 
gunk007 is offline  
Sponsored Links
Advertisement
 
#2 Old 09-30-2009, 12:15 PM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
It looks just like my 2005 auto I have. I just walked outside and checked, lol.

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
#3 Old 09-30-2009, 12:20 PM
WRXtuners Member
 
gunk007's Avatar
 
Join Date: May 2008
Location: Minnesota
Posts: 265
Images: 5
gunk007 is more helpful than not
OK, Thanks. It just look like there NEEDS to be something there.
gunk007 is offline  
#4 Old 09-30-2009, 02:16 PM
WRXtuners Member
 
Join Date: Apr 2008
Location: New York
Posts: 454
Images: 1
VisiX is a helpful contributing member
Flux capacitor is missing. It's removed so that you don't go back in time when you hit 88 MPH.
VisiX is offline  
#5 Old 09-30-2009, 02:50 PM
WRXtuners Member
 
airplnmdls's Avatar
 
Join Date: Jun 2009
Location: Ohio
Posts: 212
Images: 10
airplnmdls is an unknown
Send a message via AIM to airplnmdls
I think you're good...I know...it seems like the WHOLE engine compartment in crammed with stuff except for that little corner...O well... they probably just didn't want to put anything by the exhaust in case it got too hot...
airplnmdls is offline  
#6 Old 09-30-2009, 03:00 PM
Moderator
 
mosc's Avatar
 
Join Date: Mar 2005
Location: Pennsylvania
Posts: 6,482
Images: 7
mosc is a helpful contributing member
Garage
It's supposed to be empty. Give the turbo some room!

04 STi 16G powered lagless fun
04 WRX: SOLD
mosc is online now  
#7 Old 09-30-2009, 03:38 PM
WRXtuners Member
 
Join Date: May 2007
Location: Connecticut
Posts: 116
Jcarv20 is an unknown
thats where the NOS goes lol, but seriously i have the same car its fine
Jcarv20 is offline  
#8 Old 09-30-2009, 04:48 PM
WRXtuners Member
 
booosted09's Avatar
 
Join Date: Jun 2009
Location: Massachusetts
Posts: 477
Images: 5
booosted09 is more helpful than not
Garage
Quote:
Originally Posted by Jcarv20 View Post
thats where the NOS goes lol, but seriously i have the same car its fine

so stock its not even funny...just kinda sad :(
-Randy
booosted09 is offline  
#9 Old 09-30-2009, 08:07 PM
WRXtuners Member
 
04paulieWRX's Avatar
 
Join Date: Jan 2008
Location: New York
Posts: 233
04paulieWRX is an unknown
yea u need to have a gt35 turbo sitting right about there
04paulieWRX is offline  
#10 Old 10-01-2009, 12:12 AM
WRXtuners Member
 
man show's Avatar
 
Join Date: Apr 2007
Location: Maryland
Posts: 3,139
Images: 2
man show is a WRX expert worth listening to man show is a WRX expert worth listening to man show is a WRX expert worth listening to
Rotated mount! Yeeeeeeaaahhhhh

John
07 WRX
man show is offline  
#11 Old 10-01-2009, 12:17 AM
WRXtuners Member
 
jdowrx's Avatar
 
Join Date: Jan 2008
Location: California
Posts: 81
Images: 2
jdowrx is an unknown
The only thing i see missing is the cover for the boost solenoid.
jdowrx is offline  
#12 Old 10-01-2009, 08:14 PM
WRXtuners Member
 
09azwrx's Avatar
 
Join Date: Aug 2009
Location: Arizona
Posts: 51
Images: 2
09azwrx is an unknown
Ok, so i don't see Waldo any were.
09azwrx is offline  
#13 Old 10-02-2009, 11:54 AM
WRXtuners Member
 
phatmike0704's Avatar
 
Join Date: May 2008
Location: Illinois
Posts: 147
phatmike0704 is an unknown
Send a message via AIM to phatmike0704 Send a message via Yahoo to phatmike0704
coilover maybe? loll
phatmike0704 is offline  
#14 Old 10-02-2009, 12:44 PM
WRXtuners Member
 
WRXParamedic's Avatar
 
Join Date: Sep 2008
Location: Oklahoma
Posts: 81
WRXParamedic is an unknown
Thats exactly what I thought when I first opened the hood of my 05. I saw an unoccupied bolt hole on the intercooler mount and figured something was taken off by the previous owner but looking under the hood of an STI it was clear that the intercooler was bigger and the WRX used the same IC mount on a smaller IC.
WRXParamedic is offline  
#15 Old 10-02-2009, 12:48 PM
WRXtuners Member
 
gunk007's Avatar
 
Join Date: May 2008
Location: Minnesota
Posts: 265
Images: 5
gunk007 is more helpful than not
WRPara, That is what scared me. WHY would there be a bolt hole with nothing attached??? It is nice that everyone can confirm that there is nothing wrong except for the missing flux capacitor
gunk007 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On