Post TBE and uppipe install problems - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 05-24-2010, 09:35 AM
WRXtuners Member
 
Join Date: Feb 2010
Location: Ohio
Posts: 24
Images: 2
footbkosec20 is an unknown
Send a message via AIM to footbkosec20
Post TBE and uppipe install problems

Hello all. I recently replaced my entire TBE and uppipe on my 04 WRX. Parts included a CNT catted dp, SRS catback and a grimmspeed ceramic coated uppipe. Install wasn't too bad and was eventually completed. Once I had finally started the car up I thought all was fine until I had looked underneath for air leaks. I found oil gushing from the bottom of the vehicle. I immediately shut the car down. Upon further inspection I found the oil line to cool the turbo had come off during the exhaust install. I had to take the downpipe off and loosen the uppipe again so I could raise the turbo enough to reattach the oil line. Once again, i replaced all other parts and had everything back together and started the car. This time there were no air leaks or oil leaks. I added a quart of oil once all was said and done to replace what I had lost. When all was said and done, the car sounded amazing and I was happy.

However, on my first test drive I discovered smoke pouring out of the hood scoop. This was extremely frustrating. The temp gauge is good and engine temps all appear to be normal. I am hoping this smoke is from the PB blaster used to loosen bolts and possibly the oil that had spilled out during the first install that is just burning off. The smoke appears after driving the car for about 10 min.

My question is, is there a separate line for the oil to cool the turbo? I have ensured the oil levels for the car are as they should be. I am just worried about letting the car run with smoke. Has anyone else experienced this problem?

Thanks for any help.

-Marc
footbkosec20 is offline  
Sponsored Links
Advertisement
 
#2 Old 05-24-2010, 09:48 AM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
What color is the smoke? What does it smell like?

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
#3 Old 05-24-2010, 10:39 AM
WRXtuners Member
 
Join Date: Sep 2009
Location: Michigan
Posts: 2,158
RcrsWetDream is known to be trustworthy and helpful RcrsWetDream is known to be trustworthy and helpful
My car smoked like hell from the mixture of pb blaster, anti-seize, and heat wrap... Makes you think your car is on fire but it's not. You may also be burning off the oil that went everywhere.

-Chris
RcrsWetDream is offline  
#4 Old 05-24-2010, 12:11 PM
WRXtuners Member
 
Join Date: Feb 2010
Location: Ohio
Posts: 24
Images: 2
footbkosec20 is an unknown
Send a message via AIM to footbkosec20
Smoke appears to be coming from below the turbo. also reaks like the PB blaster and somewhat like oil. Just shivers me timbers seeing smoke come out of the hood scoop. It is white smoke.
footbkosec20 is offline  
#5 Old 05-24-2010, 02:39 PM
WRXtuners Member
 
Join Date: Sep 2009
Location: Michigan
Posts: 2,158
RcrsWetDream is known to be trustworthy and helpful RcrsWetDream is known to be trustworthy and helpful
Mine was comin out the scoop too. It'll go away pretty quick if that's all it is.

-Chris
RcrsWetDream is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On