overheating?? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 02-08-2010, 04:22 PM
WRXtuners Member
 
Join Date: Feb 2010
Location: Florida
Posts: 1
jayfresh09 is an unknown
overheating??

hey guys, well my car is overheating and i have no idea why, does any one have any suggestions? please anye help would be great...
jayfresh09 is offline  
Sponsored Links
Advertisement
 
#2 Old 02-08-2010, 04:59 PM
WRXtuners Member
 
ratfink's Avatar
 
Join Date: Oct 2008
Location: Idaho
Posts: 518
ratfink is a helpful contributing member
Well.....check the coolant level, if ok then check fan operation, if ok check if t-stat is stuck shut, if ok check for radiator obstruction etc. Let us know what you've checked.

Brad

AEM CAI, Perrin ELH wrapped, Catted Downpipe, Stage II XPT tune, K4RT30Y STS, lip, shark fin
ratfink is offline  
#3 Old 02-09-2010, 05:46 PM
WRXtuners Member
 
VD5505's Avatar
 
Join Date: Oct 2006
Location: Iowa
Posts: 905
Images: 6
VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful
Send a message via AIM to VD5505 Send a message via MSN to VD5505
well i would start out by starting the car when its cold and take off the reservoir cap and watch to see if you can see the water move in that, if you can see it move that means the water pump is working. If that checks out ok i would take out your radiator and flush that out really well, while that is out just buy a good thermostat and put that in anyways its cheap and its a good thing to do anyways. While you are this far into give your radiator hoses and clams a good looking over and make sure those do not need replaced. Then put fresh new coolant in that and make sure you bleed out the system really well. Now on the 02-03 i know there isnt a radiator cap on the radiator so i always filled the coolant threw the upper hose then put that back on then filled the rest with the top reservoir. Try that and let us know how that works. If it's a water pump they are not that hard to put just takes some time.

2003 WRX Hybrid build,

Brian
VD5505 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On