Oil supply screen for turbo????? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 01-25-2009, 03:17 PM
WRXtuners Member
 
Deshi's Avatar
 
Join Date: Jan 2009
Location: Colorado
Posts: 25
Deshi is an unknown
Oil supply screen for turbo?????

I am reading up on turbos and came accross this little article and was just curious if our cars, i.e. 2002-2003 WRX's, have this screen?
Turbo Oil Starvation and Subaru Vehicles## 11
I am dealing with a possible oil starved turbo right now and was wondering if this could be the reason? The acticle says 2.5l motors but I am just curious if we have one as well.
Thanks for your help guys.

Last edited by Deshi; 01-25-2009 at 05:16 PM.
Deshi is offline  
Sponsored Links
Advertisement
 
#2 Old 01-25-2009, 06:34 PM
WRXtuners Member
 
DreamEvil's Avatar
 
Join Date: Feb 2008
Location: New Jersey
Posts: 318
Images: 7
DreamEvil is an unknown
I believe we do, I am not 100% certain, when I ordered my turbo I was asking them various questions. I heard about how you need to remove the oil screen when putting the new turbo in so I asked him about that (I mentioned my car year 2003) and he said that I would need to take the oil screen out. How ever a friend of mine, he has a 2003 as well, replaced his turbo and there was no oil screen there so I don't know if that means the previous owner removed it or if we simply do not have one. Not sure that I was of any help but I tried? lol

Dream Evil
DreamEvil is offline  
#3 Old 01-26-2009, 12:03 AM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,371
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
No, you do not. Its a 2.5L engine related issue. Much like the 2.0 has a crap UP cat and the 2.5s don't. I base this off dumdum's expertise and the fact that the article clearly states its a 2.5 L issue. There is a Subaru Service bulletin also...stating it's a 2.5 issue. 07s don't have the screen from what I remember. Much like the fact that the AVCS screen was pulled in early 05.
turmic is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On