Larger TMIC problem HELP! - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 07-16-2006, 11:30 PM
WRXtuners Member
 
Join Date: Mar 2005
Location: California
Posts: 11
scoobnoob is an unknown
Larger TMIC problem HELP!

I got a larger tmic for my wrx. For some reason when it is on the car almost stalls when you turn the car on and when you drive the car the engine idles hard and when you come to a stop it almost stalls as well. The mods on my car are a turboback exhaust, uppipe and the cobb stage 2 tune. Is it because the turbo is stock or is it because there could be a leak? I checked all the clamps and i couldnt hear any air comming out but I dont know.

any help would be great. Thanks.
scoobnoob is offline  
Sponsored Links
Advertisement
 
#2 Old 07-16-2006, 11:34 PM
WRXtuners Member
 
need2boost's Avatar
 
Join Date: Mar 2006
Location: Arkansas
Posts: 63
need2boost is an unknown
sounds like you have a boost leak/vacuum leak, recheck all connections for your intercooler including BOV mount, I'm almost willing to bet that you have a leak somewhere in your system. make a boost leak tester if you have to, that will pinpoint your leak.
need2boost is offline  
#3 Old 07-17-2006, 01:39 AM
WRXtuners Member
 
awd>fwd's Avatar
 
Join Date: Sep 2005
Location: Washington
Posts: 1,746
Images: 4
awd>fwd is an unknown
Send a message via AIM to awd>fwd
Did you upgrade the hoses? It almost sounds like your hose isn't connected...

Brent
2007 Satin White STi, 1989 Nissan Sil-Coupe, 1998 Toyota 4runner (to be built..)...
awd>fwd is offline  
#4 Old 07-17-2006, 01:14 PM
WRXtuners Member
 
9d2TSi's Avatar
 
Join Date: Mar 2005
Location: Michigan
Posts: 3,171
Images: 5
9d2TSi is more helpful than not
Send a message via AIM to 9d2TSi Send a message via MSN to 9d2TSi
I'm willing to bet it's a leak as well. Check your IC piping again.

My car is well, it's like 10 lbs of shit in a 5 lb bag...

<------ Click to see what I'm workin' with. ;)
9d2TSi is offline  
#5 Old 07-17-2006, 01:38 PM
WRXtuners Member
 
six3jag's Avatar
 
Join Date: Dec 2004
Location: Texas
Posts: 366
Images: 2
six3jag is an unknown
Send a message via AIM to six3jag
Leak. When i did this i noticed the hose from the throttle to the IC tends to get pinched on the bottom side. same for the hose to turbo connection. I would bet one of those is it.

Jacob
Almost clean wrx...
six3jag is offline  
#6 Old 07-17-2006, 01:57 PM
WRXtuners Member
 
JiveMasterT's Avatar
 
Join Date: Jan 2006
Location: New York
Posts: 677
Images: 5
JiveMasterT is more helpful than not
Definitely a leak. Check it.

Patrick - 2007 STi Limited
▼SbiΣ Mi▼
JiveMasterT is offline  
#7 Old 07-17-2006, 02:43 PM
WRXtuners Member
 
Join Date: Mar 2005
Location: California
Posts: 11
scoobnoob is an unknown
I found the leak. Thank you guys for the help . Problem Solved.
scoobnoob is offline  
#8 Old 07-17-2006, 02:44 PM
WRXtuners Member
 
Join Date: Mar 2005
Location: California
Posts: 11
scoobnoob is an unknown
Quote:
Originally Posted by six3jag
Leak. When i did this i noticed the hose from the throttle to the IC tends to get pinched on the bottom side. same for the hose to turbo connection. I would bet one of those is it.

It was the hose to the turbo. Thanks for the advice.
scoobnoob is offline  
#9 Old 07-17-2006, 03:05 PM
Vew
Moderator
 
Vew's Avatar
 
Join Date: Feb 2004
Location: West Virginia
Posts: 3,451
Images: 10
Vew is more helpful than not
Send a message via AIM to Vew
You guys are so smart. WRX love everyone

Jon
"We live for a good time, not a long time."
RIP Colin McRae
Vew is offline  
#10 Old 07-17-2006, 03:20 PM
WRXtuners Member
 
Join Date: Apr 2005
Location: Michigan
Posts: 924
shamrock is an unknown
Well done

_Ryan_
2004 Wrb "BUGEYE"
http://www.misubie.com/
shamrock is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On