How many washers you got in your turbo xs BOV? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 07-07-2005, 04:21 PM
WRXtuners Member
 
Join Date: Oct 2003
Location: New York
Posts: 350
Images: 7
wrxtacy19 is an unknown
How many washers you got in your turbo xs BOV?

how many ya got?
wrxtacy19 is offline  
Sponsored Links
Advertisement
 
#2 Old 07-07-2005, 07:52 PM
WRXtuners Member
 
Join Date: Jun 2004
Location: Wisconsin
Posts: 189
My05WRX is an unknown
Send a message via AIM to My05WRX
2 but i think i need more..
My05WRX is offline  
#3 Old 07-08-2005, 08:49 AM
WRXtuners Member
 
Join Date: Oct 2003
Location: New York
Posts: 350
Images: 7
wrxtacy19 is an unknown
spoke to turbo xs and they say 4
wrxtacy19 is offline  
#4 Old 07-08-2005, 08:57 AM
WRXtuners Member
 
03wrxwgn's Avatar
 
Join Date: Mar 2005
Location: Texas
Posts: 410
Images: 6
03wrxwgn is an unknown
I have zero washers in mine! Going on 9 months...
03wrxwgn is offline  
#5 Old 07-08-2005, 10:58 AM
WRXtuners Member
 
Wukillabee56's Avatar
 
Join Date: Mar 2005
Location: Maryland
Posts: 112
Images: 11
Wukillabee56 is an unknown
Send a message via AIM to Wukillabee56
I got one and running fine
Wukillabee56 is offline  
#6 Old 07-08-2005, 12:35 PM
WRXtuners Member
 
panasyncp17's Avatar
 
Join Date: Mar 2005
Location: Connecticut
Posts: 462
Images: 9
panasyncp17 is an unknown
Send a message via AIM to panasyncp17
I have 4.
panasyncp17 is offline  
#7 Old 07-08-2005, 02:03 PM
WRXtuners Member
 
Cosmo's Avatar
 
Join Date: Dec 2002
Location: Virginia
Posts: 4,591
Images: 15
Cosmo is known to be trustworthy and helpful Cosmo is known to be trustworthy and helpful
Send a message via AIM to Cosmo
When I put a new RFL on a car, I start with two. I have yet to see a car that will run well with less than that. They leak badly with one or none (at least, in my experience). For a car with an aftermarket turbo, I start with 4. I had 5 in mine before I got rid of it.
Cosmo is offline  
#8 Old 07-08-2005, 03:11 PM
WRXtuners Member
 
Join Date: Feb 2005
Location: New York
Posts: 204
jeff04 is an unknown
I ran mine with none for awhile, then I figured out that four was right for my car. They stopped the car from idling low and bogging down. But I sold it and now have a hks ssqv.
jeff04 is offline  
#9 Old 07-09-2005, 10:21 AM
WRXtuners Member
 
Join Date: Oct 2003
Location: New York
Posts: 350
Images: 7
wrxtacy19 is an unknown
is the HKS a 50/50?
wrxtacy19 is offline  
#10 Old 07-09-2005, 05:15 PM
WRXtuners Member
 
Join Date: Feb 2005
Location: New York
Posts: 204
jeff04 is an unknown
No. 100% atmospheric.
jeff04 is offline  
#11 Old 07-10-2005, 07:01 AM
WRXtuners Member
 
Join Date: May 2005
Location: Arizona
Posts: 34
Images: 4
ToyMachineAR is an unknown
Send a message via AIM to ToyMachineAR
Quote:
Originally Posted by jeff04
I ran mine with none for awhile, then I figured out that four was right for my car. They stopped the car from idling low and bogging down. But I sold it and now have a hks ssqv.
I'm currently running "none", but I have no problem with idling low, or bogging down, etc. I started w 2, and it seemed really quiet (because the spring rate was higher inside.. thats the point of the washers, right..) so I took em out, and it got a little louder.
I think i'll put one in for a compromise in my mind.
Jeff
ToyMachineAR is offline  
#12 Old 07-10-2005, 12:12 PM
WRXtuners Member
 
Join Date: Feb 2005
Location: New York
Posts: 204
jeff04 is an unknown
When I had no washers in mine, every time I started the car the idle would be really low then start to come back up. Same thing when taking off at a stop light. I had to rev it up a little higher or it would bog a little. Then I started to adjust the bov with the washers and found that four worked the best. And yes, with the four washers in place the bov did sound different.
jeff04 is offline  
#13 Old 07-18-2005, 06:01 PM
WRXtuners Member
 
Join Date: May 2005
Location: Arizona
Posts: 34
Images: 4
ToyMachineAR is an unknown
Send a message via AIM to ToyMachineAR
I'm angry about this thread now.. I thought i'd "go with everyone's advice" and put 4 washers in mine, but it ran like sh*t! The blow off was weak, and wouldn't make a sound until 5500rpm.
Now I have one, and i'm getting an RPM spike every once in a while..
I'm going to take out the one and run zero again.
Jeff
ToyMachineAR is offline  
#14 Old 07-18-2005, 07:23 PM
WRXtuners Member
 
TruBluWRX's Avatar
 
Join Date: Nov 2004
Location: Washington
Posts: 97
Images: 24
TruBluWRX is an unknown
Send a message via AIM to TruBluWRX Send a message via MSN to TruBluWRX
About that...

I have an RFL, and honestly, if you dont have enough washers in it, even if your car runs fine, it blows off like a leaky vag and personally gets a little annoying. I run with three washers in it (stock turbo, soon to change though!) and my car runs fine and it doesnt release an ear-splitting pppfffffsssshhhhh every time i pass 500 rpm.

Just my .02 though

*TBRex* 02 WRB WRX Wagon
TruBluWRX is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On