help with a blow off valve - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 01-13-2006, 09:34 PM Thread Starter
WRXtuners Member
 
Join Date: Jan 2006
Location: New York
Posts: 2
dj'swrx2003 is an unknown
help with a blow off valve

i have a blow off valve and i hear nothing but fluttering unless i damn near red line the car. i have a blow off valve that has a turn knob on the top of the valve it dosent use washers how do i adjust it? it also connects to the stock hose that went to the other valve


if it matters i have a ingen short ram on the car and a magna flow down pipe, and exaust???
dj'swrx2003 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 01-14-2006, 12:21 AM
WRXtuners Member
 
imbeterthanu's Avatar
 
Join Date: Oct 2004
Location: Florida
Posts: 975
Images: 4
imbeterthanu is an unknown
Send a message via AIM to imbeterthanu
is it the forge BOV? i should have came with differnet spring adjustments.
imbeterthanu is offline  
post #3 of 6 Old 01-14-2006, 12:35 AM
WRXtuners Member
 
9d2TSi's Avatar
 
Join Date: Mar 2005
Location: Michigan
Posts: 3,171
Images: 5
9d2TSi is more helpful than not
Send a message via AIM to 9d2TSi Send a message via MSN to 9d2TSi
Quote:
Originally Posted by dj'swrx2003
i have a blow off valve and i hear nothing but fluttering unless i damn near red line the car. i have a blow off valve that has a turn knob on the top of the valve it dosent use washers how do i adjust it?
What kind is it?

Try turning it out and then start turning it back in until this problem goes away. Small turns (less than a full one each time) should fix your problem.

My car is well, it's like 10 lbs of shit in a 5 lb bag...

<------ Click to see what I'm workin' with. ;)

Last edited by 9d2TSi; 01-14-2006 at 12:44 PM.
9d2TSi is offline  
post #4 of 6 Old 01-14-2006, 10:02 AM Thread Starter
WRXtuners Member
 
Join Date: Jan 2006
Location: New York
Posts: 2
dj'swrx2003 is an unknown
it's a gfb???? a friend of mine totled his sti and gave it to me for free the only reason i took it is because it bolted right in the intercooler using the stock holes; i didn't have to custom make anything
dj'swrx2003 is offline  
post #5 of 6 Old 01-14-2006, 10:58 AM
WRXtuners Member
 
ManicsWrX's Avatar
 
Join Date: Aug 2005
Location: Pennsylvania
Posts: 1,722
Images: 8
ManicsWrX is more helpful than not
Send a message via AIM to ManicsWrX
Take the top off make sure the spring is not stretched or worn. Should be spacers also, depeding on that model I would look into that online and check. Maybe turn it to adjust it....sounds way to tight

Chris- ▼SbiΣ Mi▼
242 AWHP / 318 TQ
ManicsWrX is offline  
post #6 of 6 Old 01-14-2006, 12:50 PM
WRXtuners Member
 
9d2TSi's Avatar
 
Join Date: Mar 2005
Location: Michigan
Posts: 3,171
Images: 5
9d2TSi is more helpful than not
Send a message via AIM to 9d2TSi Send a message via MSN to 9d2TSi
Some interesting reading.

http://www.gofastbits.com.au/index.p...tion=tech_info

My car is well, it's like 10 lbs of shit in a 5 lb bag...

<------ Click to see what I'm workin' with. ;)
9d2TSi is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome