Helix Uppipe - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 01-04-2006, 04:02 PM Thread Starter
WRXtuners Member
 
04rex's Avatar
 
Join Date: Dec 2005
Location: Ontario, Canada
Posts: 44
04rex is an unknown
Helix Uppipe

Ok, so if i want to change the uppipe to the helix flex uppipe, what types of problems am i going to come into? i.e no more, so check engine light and so forth. how how do i fix these problems, or does the uppipe come with the fix automatically.

I am new to the scene. I always see you guys post things such as "throwing a cel" after installing an uppipe. what exaclty does that mean and and do i avoid that?

A buddy of mine wants to do the cobb stage II. We know that it betters the timing and all that stuff, but will it also waste alot more gas than normal, or will it be hardly noticable?

thanks guys!!
04rex is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 01-04-2006, 06:58 PM
Ian
Moderator
 
Ian's Avatar
 
Join Date: Dec 2003
Location: Connecticut
Posts: 2,722
Images: 9
Ian is more helpful than not
Send a message via AIM to Ian
Most likely you will get a check engine light (CEL) but most up pipes come with a CEL fix if not you can get one, Gruppe-s.com has them.
Throwing a CEL means having a check engine light come on.
In most cases your gas milage will get better with tuning, it's the thrill of having more power that will kill your gas.

My turbo's fixed and a lot better =)
Ian is offline  
post #3 of 11 Old 01-04-2006, 07:52 PM
WRXtuners Member
 
WRXtreme's Avatar
 
Join Date: Mar 2003
Location: Pennsylvania
Posts: 1,654
WRXtreme is more helpful than not
Send a message via AIM to WRXtreme
When I installed my uppipe, I never got a CEL. My downpipe is what gave me a CEL and then I got a rear o2 sensor fix kit and no problems since. There are plenty of fixes out there for exhaust CELs, so I say go ahead and do it, then fix it if needed.
WRXtreme is offline  
post #4 of 11 Old 01-07-2006, 01:48 AM
WRXtuners Member
 
Bullit's Avatar
 
Join Date: Aug 2004
Location: Maryland
Posts: 356
Bullit is an unknown
You shouldn't get a CEL from the up-pipe, but the down-pipe is a different story. But it depends on the car. Some never get a CEL, some get it right away, some get it months later. But from what I've read, if you are planning on getting a accessport, then it will take care of that issue.

Sig edited due to rules, sorry
Bullit is offline  
post #5 of 11 Old 01-07-2006, 02:54 PM
WRXtuners Member
 
dlh1999's Avatar
 
Join Date: Nov 2005
Location: Oregon
Posts: 304
Images: 9
dlh1999 is an unknown
From what I've read & heard, either the Helix or Perrin UP's guarantee that you will not get a CEL...I think that comes from installing a catless DP like someone already mentioned.
dlh1999 is offline  
post #6 of 11 Old 01-07-2006, 10:04 PM
Vew
Moderator
 
Vew's Avatar
 
Join Date: Feb 2004
Location: West Virginia
Posts: 3,452
Images: 10
Vew is more helpful than not
Send a message via AIM to Vew
It's because they provide you with the EGT CEL fix.

Jon
"We live for a good time, not a long time."
RIP Colin McRae
Vew is offline  
post #7 of 11 Old 01-08-2006, 12:39 AM
WRXtuners Member
 
dlh1999's Avatar
 
Join Date: Nov 2005
Location: Oregon
Posts: 304
Images: 9
dlh1999 is an unknown
Quote:
Originally Posted by Vew
It's because they provide you with the EGT CEL fix.

Ah, that I haven't heard...good to know...
dlh1999 is offline  
post #8 of 11 Old 01-08-2006, 03:38 PM
WRXtuners Member
 
WRXtreme's Avatar
 
Join Date: Mar 2003
Location: Pennsylvania
Posts: 1,654
WRXtreme is more helpful than not
Send a message via AIM to WRXtreme
Quote:
Originally Posted by Vew
It's because they provide you with the EGT CEL fix.
I was not provided with anything except the uppipe and gaskets. My EGT sensor is still plugged in.
WRXtreme is offline  
post #9 of 11 Old 01-08-2006, 09:24 PM
WRXtuners Member
 
9d2TSi's Avatar
 
Join Date: Mar 2005
Location: Michigan
Posts: 3,171
Images: 5
9d2TSi is more helpful than not
Send a message via AIM to 9d2TSi Send a message via MSN to 9d2TSi
Quote:
Originally Posted by WRXtreme
I was not provided with anything except the uppipe and gaskets. My EGT sensor is still plugged in.
Me too, I think he meant the dp cel fix though.

My car is well, it's like 10 lbs of shit in a 5 lb bag...

<------ Click to see what I'm workin' with. ;)
9d2TSi is offline  
post #10 of 11 Old 01-08-2006, 09:39 PM
Vew
Moderator
 
Vew's Avatar
 
Join Date: Feb 2004
Location: West Virginia
Posts: 3,452
Images: 10
Vew is more helpful than not
Send a message via AIM to Vew
No, I was provided a resistor with my Perrin uppipe to fix the EGT CEL (go gaskets, but I planned ahead for that). My downpipe is what gave me a CEL, but I bought a seperate fix for that. And yes, with the resistor, I have never thrown the EGT CEL by the uppipe.

Jon
"We live for a good time, not a long time."
RIP Colin McRae
Vew is offline  
post #11 of 11 Old 01-09-2006, 12:48 AM
WRXtuners Member
 
9d2TSi's Avatar
 
Join Date: Mar 2005
Location: Michigan
Posts: 3,171
Images: 5
9d2TSi is more helpful than not
Send a message via AIM to 9d2TSi Send a message via MSN to 9d2TSi
Hmmm, I see now.

My car is well, it's like 10 lbs of shit in a 5 lb bag...

<------ Click to see what I'm workin' with. ;)
9d2TSi is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome