Finally got it, and installed.. DP,UP. - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 02-20-2006, 11:16 PM Thread Starter
WRXtuners Member
 
Join Date: Feb 2006
Location: Iowa
Posts: 288
Images: 3
03'WRXDriva is an unknown
Send a message via MSN to 03'WRXDriva Send a message via Yahoo to 03'WRXDriva
Finally got it, and installed.. DP,UP.

Ok, if anybody remembers my post a while back i ordered a uppipe and downpipe off ebay. It was like 129.99 b4 shipping. Well got in tin the mail today and couldnt wait took 4 hours to finish. The worst part was gettin the uppipe out of the engine compartment.

But i finally got it all off and out and stated puttin the uppipe in and it fit perfect! Came with gaskets for that and the donut gasket for the rear but no turbo gasket for the uppipe. and the uppipe fit perfect too i was amazed even the hanger. it rubs the hose on the firewall tho gonna hav to fix that.








Attached Images
     
03'WRXDriva is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 02-21-2006, 08:38 AM
WRXtuners Member
 
WRXtreme's Avatar
 
Join Date: Mar 2003
Location: Pennsylvania
Posts: 1,654
WRXtreme is more helpful than not
Send a message via AIM to WRXtreme
Glad everything worked out for you. I believe you are talking about the A/C drain hose on the firewall touching the downpipe. If you've driven it for any amount of time, its probably melted. I cut about half off mine so it wouldn't touch anymore.
WRXtreme is offline  
post #3 of 7 Old 02-21-2006, 01:34 PM
WRXtuners Member
 
poser's Avatar
 
Join Date: Jan 2006
Location: Texas
Posts: 359
poser is an unknown
129.99 for both, and it fit! cool who cares if its not name brand its cheap
poser is offline  
post #4 of 7 Old 02-21-2006, 02:53 PM
WRXtuners Member
 
bradley03's Avatar
 
Join Date: Sep 2005
Location: Washington
Posts: 428
Images: 2
bradley03 is an unknown
Very nice. Did you see a nice HP increase on the ol butt dyno?

-Brad
05 wrx sti
▼SbiΣ Mi▼
bradley03 is offline  
post #5 of 7 Old 02-21-2006, 02:57 PM
WRXtuners Member
 
Join Date: Jun 2005
Location: California
Posts: 96
jlagace is an unknown
are they the ERZ/tsudo stuff? if so, i heard you had to cut some bolts or some other weird modifications to get it to fit. anything like that happen during ## install?
thanks

02 WRX Sedan
World Rally Blue
jlagace is offline  
post #6 of 7 Old 02-21-2006, 06:16 PM Thread Starter
WRXtuners Member
 
Join Date: Feb 2006
Location: Iowa
Posts: 288
Images: 3
03'WRXDriva is an unknown
Send a message via MSN to 03'WRXDriva Send a message via Yahoo to 03'WRXDriva
No cutting of anything believe it or not i was very surprised as i stated in the first post. yeah i took it down the road and when i got back you would think i just smoked the tires off because of the hose burnin. So i ziptied it back out of the way.

As far as hp? well, it spools alot faster way more torque in first and second gear. first will set u in the seat pretty good. If your turnin at all it will roast the front tire off.

And the turbo is real loud inside the car. Also i dont know what the deal is but it almost sounds like a miss at low rpm's when your in 5th cruisin around 45mph and u give it gas the turbo sounds like its flutterin. Any ideas?

i found this obx muffler on ebay for 47 bucks with 15 dollar shipping. you i reall need to remove the resonater in front of the axle? How much diff could it make?

and as for the brand, the sell was reddoggmotorsports i think.

Attached Images
 
03'WRXDriva is offline  
post #7 of 7 Old 02-21-2006, 09:50 PM
WRXtuners Member
 
Join Date: Aug 2005
Location: North Carolina
Posts: 19
xreidpolarx is an unknown
Port out the turbo and it should go away.
xreidpolarx is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On