EGT sensor - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 19 Old 01-05-2009, 04:54 PM Thread Starter
WRXtuners Member
 
Join Date: Mar 2008
Location: Oregon
Posts: 53
TurboRyan is an unknown
EGT sensor

My car is in the shop right now having a Megan Racing Flex up-pipe installed... I am getting paranoid about the EGT sensor, i told the shop not to put it back in because it might come loose and kill my turbo. BUT will i still be able to pass emisions with out the EGT sensor? I failed emissions today because my car doesn't have an o2 sensor installed at the moment, so i don't want to add more problems to deal with in order to pass the emission test..

Question being, is it best to leave the EGT sensor out?
TurboRyan is offline  
Sponsored Links
Advertisement
 
post #2 of 19 Old 01-05-2009, 05:25 PM
WRXpert
 
dumdum's Avatar
 
Join Date: Sep 2004
Location: Virginia
Posts: 2,800
Images: 12
dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention
Why doesn't your car have an 02 sensor installed?Wise up and spend your money on some engine management before any other mods............

Homebrewed tuned with Opensource!
dumdum is offline  
post #3 of 19 Old 01-05-2009, 06:09 PM Thread Starter
WRXtuners Member
 
Join Date: Mar 2008
Location: Oregon
Posts: 53
TurboRyan is an unknown
You always have a negative comment to make huh?

I have a cobb AP v2 w/ PDX e-tune

My question being, if i remove the EGT Sensor will i have trouble passing emissions? I have the AP tuner so i can clear the code, but will that show up on the emissions test?
TurboRyan is offline  
post #4 of 19 Old 01-05-2009, 06:18 PM
WRXtuners Member
 
Join Date: May 2006
Location: California
Posts: 996
WReXd is known to be trustworthy and helpful WReXd is known to be trustworthy and helpful WReXd is known to be trustworthy and helpful
you won't have any problems if you do the resistor cel fix. you might if you use the AP to clear it... I'm not sure, though. I've cleared dtc's with enginuity (err, romraider) for emissions, and there were no problems.
WReXd is offline  
post #5 of 19 Old 01-05-2009, 06:27 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,371
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
TurboRyan: The problem being...wasn't it you? That posted earlier should you leave in the EGT or leave it out? In that post....it was said to leave it out. The 02 sensor being missing is why your failing your emission test. The AP should be clearing the codes that other wise would be causing you to fail. Why isn't the 02 sensor installed? Is a better question. If it was installed, you'd more than likely pass. I'm sure your ecu is throwing a code because the 02 isn't simply there at all.
turmic is offline  
post #6 of 19 Old 01-05-2009, 06:29 PM Thread Starter
WRXtuners Member
 
Join Date: Mar 2008
Location: Oregon
Posts: 53
TurboRyan is an unknown
After clearing the code i would just have to drive 150 or so miles untill its "ready"? Would i be better off adding the resistor fix to the egt?
TurboRyan is offline  
post #7 of 19 Old 01-05-2009, 06:29 PM
WRXpert
 
LiL Shoaf's Avatar
 
Join Date: Jun 2005
Location: Pennsylvania
Posts: 1,810
Images: 2
LiL Shoaf is more helpful than not
Send a message via AIM to LiL Shoaf Send a message via Yahoo to LiL Shoaf
I did the resistor fix on my 02 and it did the trick, no CEL..

02 WRX.. "It's fun when it runs.. Problem is that it hardly ever does..."
LiL Shoaf is offline  
post #8 of 19 Old 01-05-2009, 06:36 PM Thread Starter
WRXtuners Member
 
Join Date: Mar 2008
Location: Oregon
Posts: 53
TurboRyan is an unknown
This is my first post concerning the egt sensor...

My car isn't showing any CEL's, so i was hoping i would pass before i put the up pipe in....

The guy i bought the car from told me the o2 sensor wouldn't mount on the exhaust like it did on the stock system. (i have a 4" catless dp, 3" catless tbe).

So in order for me to reinstall the o2 sensor it seems i would need to have the mount welded into the exhaust... My dad's buddy told him about an easy fix for this prob. but my dad didn't remember what he said to do, lol.
TurboRyan is offline  
post #9 of 19 Old 01-05-2009, 06:50 PM
WRXpert
 
LiL Shoaf's Avatar
 
Join Date: Jun 2005
Location: Pennsylvania
Posts: 1,810
Images: 2
LiL Shoaf is more helpful than not
Send a message via AIM to LiL Shoaf Send a message via Yahoo to LiL Shoaf
So there is no bungs on the exhaust? Most of the time guys talk about a cel fix they are referring to a spacer. It moves the o2 out of the main stream of the exhaust which allows it to read properly even when the cat is missing.

02 WRX.. "It's fun when it runs.. Problem is that it hardly ever does..."
LiL Shoaf is offline  
post #10 of 19 Old 01-05-2009, 06:58 PM Thread Starter
WRXtuners Member
 
Join Date: Mar 2008
Location: Oregon
Posts: 53
TurboRyan is an unknown
i know for a fact there are no bungs on the down pipe, and when i was doing the turbo swap i didn't see any bungs further down the line... Where is the
o2 sensor located from the factory?
TurboRyan is offline  
post #11 of 19 Old 01-05-2009, 07:01 PM
WRXpert
 
LiL Shoaf's Avatar
 
Join Date: Jun 2005
Location: Pennsylvania
Posts: 1,810
Images: 2
LiL Shoaf is more helpful than not
Send a message via AIM to LiL Shoaf Send a message via Yahoo to LiL Shoaf
By the transmission.

Here you can see the bung for mine, it's the little tube that is sticking out of the side of my downtube..


02 WRX.. "It's fun when it runs.. Problem is that it hardly ever does..."
LiL Shoaf is offline  
post #12 of 19 Old 01-05-2009, 07:04 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,371
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
TurboRyan: Sorry, I thought that was you that posted that. The rear 02 sensor is what i'm assuming your talking about. It should be pre-cat. I'd assume. Then the cat would take care of the un-burnt fuel after the exhaust gases were read. That location would tell the ECU how rich/lean the exhaust gases are. So, that it could help adjust the mixture.
turmic is offline  
post #13 of 19 Old 01-06-2009, 11:28 AM Thread Starter
WRXtuners Member
 
Join Date: Mar 2008
Location: Oregon
Posts: 53
TurboRyan is an unknown
Being that i have no cats at all, what is the best fix for my missing o2? Have a bung welded on the dp and have it reinstalled? or just do a resistor fix?
TurboRyan is offline  
post #14 of 19 Old 01-06-2009, 01:17 PM
WRXpert
 
dumdum's Avatar
 
Join Date: Sep 2004
Location: Virginia
Posts: 2,800
Images: 12
dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention
Have a bung welded in and reinstall the sensor.Honestly ditch the AP and go Opensource for this very reason.Opensource has a "forced readiness" you can apply to your ROM that will allow it to pass OBDII emissions scans.

Homebrewed tuned with Opensource!
dumdum is offline  
post #15 of 19 Old 01-06-2009, 02:51 PM Thread Starter
WRXtuners Member
 
Join Date: Mar 2008
Location: Oregon
Posts: 53
TurboRyan is an unknown
Can i use the cable from my AP for opensource tuning? I like having the AP for the ease of switching maps and logging....
TurboRyan is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome