CEL fix with Down pipe ? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 10-03-2004, 02:46 PM
WRXtuners Member
 
vbe11's Avatar
 
Join Date: Aug 2004
Location: California
Posts: 12
vbe11 is an unknown
Question CEL fix with Down pipe ?

So I got the Helix up/dp combo. I installed the dp 2 days ago and I love it. I didn't do the uppipe yet though. My question is do I need a cel fix for the dp ? I plugged the o2 sensor back in, but it seems to me that after removing the last two cats the sensor will pick up something fishy. It's been abuot 75 miles and I havn't had one yet.
vbe11 is offline  
Sponsored Links
Advertisement
 
#2 Old 10-03-2004, 08:30 PM
WRXtuners Member
 
bah14's Avatar
 
Join Date: Jan 2004
Location: Ohio
Posts: 266
bah14 is an unknown
i have heard that some people get it and some do not. For example, on my '04 rex, no cel fix was needed. But on my buddy's '04, he needed one. Unless it's the color (which it isn't), I'm not sure what to tell you except wait and see what happens. If/when it does happen, and Cosmo has said this, don't mess around and get it dealt with fast.

Cheers!

"I hear Buschur Racing does WRX UTECs now ... oh buddy!"
bah14 is offline  
#3 Old 10-04-2004, 07:02 PM
WRXtuners Member
 
vbe11's Avatar
 
Join Date: Aug 2004
Location: California
Posts: 12
vbe11 is an unknown
allright guys I put the uppipe in today, 3 hours, no lift, in my garage went almost flawlessley. The probe on the sensor for the uppipe broke off !Cry! there's still about a third left so I just screwed it back in, works ok so far, any suggestions?
vbe11 is offline  
#4 Old 07-31-2005, 12:56 PM
WRXtuners Member
 
Join Date: Jul 2005
Location: Florida
Posts: 5
Images: 12
Mlandinez is an unknown
Any ideas on how to install Helix Cel Fix??

When I got my Nur Spec cat back exhaust install 2 days later my Check Engine Light came on. Now I bought a Helix CEL fix which the cable has 2 color a purple and blue. I know the back O2 sensor has 4 wires, and that you are not suppost to mess around with the black ones so there is a blue and white but which colors go to the Cel Fix???....any suggestions be apprecitate it!!...Thanks
Mlandinez is offline  
#5 Old 08-01-2005, 05:14 PM
WRXtuners Member
 
trek98xc's Avatar
 
Join Date: May 2005
Location: Illinois
Posts: 706
trek98xc is an unknown
Send a message via AIM to trek98xc
you will probably need the cel fix with the downpipe but not the uppipe. if you get an accessport or utec you wont need the fixes. you may have not encountered a light yet because with the obd2 the problem has to happen twice before a light pops up.
trek98xc is offline  
#6 Old 08-01-2005, 05:33 PM
WRXtuners Member
 
Jave's Avatar
 
Join Date: Nov 2004
Location: Oklahoma
Posts: 1,577
Images: 6
Jave is more helpful than not
my Helix Combo came with the CEL fix and instructions. If no one else helps you by tomorrow I can crawl under my car after I wake up.. No point in doing it when I get off tonight as it will be dark.
Jave is offline  
#7 Old 08-05-2005, 07:34 PM
WRXtuners Member
 
Join Date: Jul 2005
Location: Florida
Posts: 5
Images: 12
Mlandinez is an unknown
I will apprecitate it, I have 4 wires I know it goes on the blue and white but like i said my cell is Purple on one end and blue in the other end. Thanks
Mlandinez is offline  
#8 Old 08-08-2005, 04:06 PM
WRXtuners Member
 
Join Date: Feb 2005
Location: New York
Posts: 204
jeff04 is an unknown
I have the Helix tbe and uppipe, all catless. I got the cel fix wired in and the light came on awhile after two times. Now I have to get that resistor or what ever from Radio Shack. Anybody know exactly what it is? I tried searching to find out what it is but I couldn't find it.
jeff04 is offline  
#9 Old 08-08-2005, 04:17 PM
WRXtuners Member
 
Jave's Avatar
 
Join Date: Nov 2004
Location: Oklahoma
Posts: 1,577
Images: 6
Jave is more helpful than not
Mlandinez

I just noticed your reply. I will check tomorrow, again cause I am already at work...
Jave is offline  
#10 Old 08-09-2005, 11:34 AM
 
IBAUCLAPlaya's Avatar
 
Join Date: Oct 2003
Location: Ohio
Posts: 3,488
Images: 8
IBAUCLAPlaya is known to be trustworthy and helpful IBAUCLAPlaya is known to be trustworthy and helpful
Send a message via AIM to IBAUCLAPlaya
2.2 k ohm
IBAUCLAPlaya is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On