2003 wrx boost leak? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 03-24-2013, 06:21 AM
WRXtuners Member
 
Join Date: Mar 2013
Location: California
Posts: 4
Frankc07 is an unknown
2003 wrx boost leak?

Hey guys I just bought a 2003 wrx with 86k miles on it. From my understanding the guy told me he gutted the uppipe. He didn't do the resistor mod so I ended up doing it. No big deal lol. Anyways whenever I'm driving the car semi hard around 4-5+ rpms my boost gauge needle tapers off and then goes back up and does it again. Almost like the turbo isn't keeping boost. I checked my oil and noticed it was low maybe that could be a issue? The guy told me it does that because it doesn't have a car back and only a stock exhaust. I don't know if I believe him. Any advice would be much appreciated. Car is stock besides a 3' turbo inlet
Frankc07 is offline  
Sponsored Links
Advertisement
 
#2 Old 03-24-2013, 11:23 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Check your bcs. Also do a boost leak test. Check under the TMIC for that connection first.

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#3 Old 03-25-2013, 07:25 AM
WRXtuners Member
 
Join Date: Mar 2013
Location: California
Posts: 4
Frankc07 is an unknown
Well news update. The guy who I bought it from has a tune on the car still. The boost is set to 17psi because he had a turbo back on it. So he's gona fix it and put it back to stock maps and turn boost down. I'm hoping this is the reason why. I have stock exhaust. I'm thinking the car Ecu as of now is like "wtf there's no more big air flow from the car back wtf?!" So I'm guessing he tuned it for just the exhaust. Who knows what esle he had on the car last.
Frankc07 is offline  
#4 Old 03-25-2013, 08:19 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Was it opensourced? Or did he have an AP ?

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#5 Old 03-25-2013, 09:19 AM
WRXtuners Member
 
Join Date: Mar 2013
Location: California
Posts: 4
Frankc07 is an unknown
I have no clue. What's the difference? I'm kind of new to this. I haven't gotten the stock map reinstalled yet doing it today. I checked my boost controller solenoid and one of the hoses was broken in half. I tried that but still same systems. I know the egt sensor isn't in the uppipe.
Frankc07 is offline  
#6 Old 03-25-2013, 10:51 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
You will be able to tell when he flashes it back to the stock map.

AP=a gameboy looking thing.

OS=Laptop and/or desktop with a cable from the competer to the ECU

Ohh the joys of buying a modded car.

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#7 Old 03-25-2013, 10:58 AM
WRXtuners Member
 
Join Date: Mar 2013
Location: California
Posts: 4
Frankc07 is an unknown
Well either way ill get stock maps back. I'm guessing its the ap one because he was going to meets half way. Idk what I'm going to do if this doesn't fix the problem... I hope it does.
Frankc07 is offline  
#8 Old 03-25-2013, 12:04 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Turbo inlet, gutted up pipe, and who knows what else. I'd still get a tune.

Paul
2007 XT
2007 MS3
pzr2874 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On