Royal Purple, Good or bad for 04 Wrx - Page 3 - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
#31 Old 02-19-2010, 08:30 AM
WRXtuners Member
 
c2bcoolwrx's Avatar
 
Join Date: Feb 2008
Location: Florida
Posts: 309
c2bcoolwrx is more helpful than not
+1 to using synthetic and changing it regularly. It is more important to have clean/fresh oil and the right amount of oil, then the brand.

I use Royal Purple 10w30 (per my engine builder/tuner's instructions) and have had good results (knock on wood). I just change it regularly, about every 3500-4000 miles and always use a new Puraltor One filter. Since I have an oil pressure gauge I always keep a close eye on my oil pressure and make sure to warm the car up (drive easy/stay out of boost) until the engine temps warm up properly.

Additionally, I also clean my MAF once a year or so (whether it is really dirty or not) and clean/change my air filter every 15-20K miles.
c2bcoolwrx is offline  
Sponsored Links
Advertisement
 
#32 Old 02-20-2010, 07:20 PM
WRXtuners Member
 
Join Date: Jan 2010
Location: Texas
Posts: 27
Nekoawag04 is an unknown
Thanks to all for your input. For the noise that i hear, I realized that it only makes the noise when am holding the gas over 3000 rpms. When I get on it a little more it stops, but when I let it go it makes the noise again. not to sure whats up.
Nekoawag04 is offline  
#33 Old 02-24-2010, 03:42 PM
WRXtuners Member
 
Join Date: Jan 2010
Location: Utah
Posts: 31
Images: 4
WRXnewB is an unknown
Been able to look into this anymore yet?
WRXnewB is offline  
#34 Old 02-24-2010, 05:33 PM
WRXtuners Member
 
Join Date: Jan 2010
Location: Texas
Posts: 27
Nekoawag04 is an unknown
Ok so the noise is only when I let off the gas pedal over 3000 rpms. What is this from? Also this is my first Subura or turbo and I heard that they both just have noises that they make. I also get a little valve nock when I rev it. Is this common?
Nekoawag04 is offline  
#35 Old 02-24-2010, 05:48 PM
WRXtuners Member
 
Join Date: Jan 2010
Location: Utah
Posts: 31
Images: 4
WRXnewB is an unknown
Quote:
Originally Posted by Nekoawag04 View Post
Ok so the noise is only when I let off the gas pedal over 3000 rpms. What is this from? Also this is my first Subura or turbo and I heard that they both just have noises that they make. I also get a little valve nock when I rev it. Is this common?
I don't think a shuddering like you are describing is very normal.

As for the valves, seeing as your car has over 100,000 miles, I would recommend at least getting in the head and inspecting your valves, seats, guides etc... if you haven't already just to make sure everything is in good working order.
WRXnewB is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On