Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Newbie Forum (http://www.wrxtuners.com/forums/f51/)
-   -   New to subarus and this site (http://www.wrxtuners.com/forums/f51/new-subarus-site-33464/)

WORX661 01-07-2013 09:44 PM

New to subarus and this site
 
9oHey hows it going everyone? Well Ive been wanting to get a subie for a while, I finally got one yesterday. Traded my gs400 for a 02 wrx sedan. I had to tow the car home due to the car not running right, its running really rich. I'll apologize now if im posting out of place. I dont know where to start to get it running better. The car is running on turboxs utec ecu and apexi avc. has a TBE, FMIC, GREDDY RS BOV. Thats all I know as far as mods. It has a wideband(which im not sure if its properly). the car does idles fine now after changing the plugs(old ones were fouled).car runs really hesitate then runs good once it hits 6psi it feels like it hits fuel cut. I just got a adapter for the serial port so im going do some data logging and hopefully i can post it up on here and maybe you guys can help a little more. ill will be tuning it as soon as i can get it to run better, i just wanna get it running ok to see if it has any other issues before i go out to tune it. Thanks in advance for the help guys. relly looking forward to being part of the subaru community

WORX661 01-08-2013 12:24 AM

so after messing with it a little bit.(way different than hondata what i am used to) the ecu was tuned to 720 injectors and 16psi. i switched it to 440's since thats whats installed. car idles a lil low now runs smoother until it hits boost then it starts to sputter. im guessing it has something to do with the map its running. ill be reading more on how to tune with the utec at least to the point where i can download a stock map into the ecu or a stage 1-2.

pzr2874 01-08-2013 05:40 AM

Welcome,

Have you considered a COBB AP for a tuning source?

WORX661 01-08-2013 08:17 AM

No I haven't but, from what I have been reading seems like that's the way to go. The utec is kinda out dated

WORX661 01-08-2013 09:59 PM

Well I got her running a lot better. No bogging no sputtering. But I do have a oil leak. It around the turbo area. I can see oil going down the dp and bell housing. I believe my turbo is blown. Imma try some oil dye. Can anyone tell me some common oil leaks on these cars?

pzr2874 01-09-2013 05:45 AM

turbo seals, feed line, PCV

WORX661 01-09-2013 01:08 PM

Do they require 2 PCV valves??ill pick some up on the way home along with the engine oil dye

pzr2874 01-09-2013 01:14 PM

One IIRC

WORX661 01-09-2013 06:35 PM

So I did the engine dye. Looks like its going to be the return line. I can't ru get good view but the bottom side of the exh housing is covered with oil n the bellhousing.



Well after checking it out some more I couldn't see any oil coming off the return line, but more from the dp flange. I took off the down pipe, and it's nice n wet so I'm saying blown turbo.

WORX661 01-09-2013 10:05 PM

Got the turbo off. I have a momentum EJ5-40T. which the company don't exist anymore. hopefully i can source a rebuild kit or local company can rebuild it for me(never rebuilt a turbo before, have tooken plenty apart though lol)

WORX661 01-09-2013 11:23 PM

[IMG]http://i260.photobucket.com/albums/ii11/worx14/00504832-03C4-4BA3-AA4C-330D02CFE534-6158-0000028A808908C7.jpg[/IMG]

pzr2874 01-10-2013 05:45 AM

Boo on that.

Consider an AP and another turbo setup.

Good luck

WORX661 01-10-2013 08:03 AM

Well I got a AP v2. Now I just need another ecu. I might just get this one rebuilt depending on the price.

pzr2874 01-10-2013 08:28 AM

Used 02WRX ECU's go for close to nothing on NASIOC.

BLAZE2099 01-10-2013 12:58 PM

And a good used low miles turbo too.


All times are GMT -5. The time now is 05:10 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.