new to the subaru world Have some problems please help :) - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 03-01-2013, 09:21 PM
WRXtuners Member
 
Join Date: Mar 2013
Location: Virginia
Posts: 3
xxking9 is an unknown
new to the subaru world Have some problems please help :)

Hello everyone i just purchased my first subaru 06 wrx from carmax yesterday, it took me a few days to get the car because they had to install a new Air pump. along with tires. when i picked up the car the check engine light was on but all the techs had gone home. i ran the code and it was a secondary air intake code and a air intake solenoid code. i cleared them and the lights stayed off for an hour or so. when i came back outside to go for another spin around the block the light was back on. after i let it warmed up i did a healthy but not retarded 1st to 2nd gear pull then....... my cruise light started flashing along with the lights that illuminate mileage and outside temp. however when the headlights are off the mileage and outside temp lights don't flash. as this is my first wrx i do not know how its is supposed to feel, but have owned several boosted cars this one seems to lag a little and kinda hesitate at first. i have looked through the forums i see alot of similar things with boost creep and aftermarket exhaust and down pipes not being tuned. My car is 100% bone stock. everything! factory minus a crap sony head unit. any ideas? i tried taking the battery loose for 30 mins and restarting it all went back to normal for a min then call came back on.

any info would help me out alot .i will have more questions but i don't want to get ahead of myself asking questions about stuff that doesn't matter until this is fixed.

Also does anyone know if i do the intake silencer mod will that terminate my warranty.
xxking9 is offline  
Sponsored Links
Advertisement
 
#2 Old 03-01-2013, 11:02 PM
WRXtuners Member
 
Join Date: Mar 2013
Location: Virginia
Posts: 3
xxking9 is an unknown
Just got told its common and it sounds like im hitting fuel cut and boost spike to 15ish psi but it shouldnt if the car is as stock as it is, also possible someone left a partial tune on it when they sold it to carmax any opinions???? anyone??????? anyone?????
xxking9 is offline  
#3 Old 03-02-2013, 02:44 PM
WRXtuners Member
 
Join Date: May 2006
Location: Virginia
Posts: 2,338
Images: 9
brfatal is a WRX expert worth listening to brfatal is a WRX expert worth listening to brfatal is a WRX expert worth listening to
Garage
Clearing the CEL is pointless as that doesn't fix the cause. I can't say I've heard of a stock car overboosting and hitting fuel cut.
brfatal is offline  
#4 Old 03-02-2013, 03:34 PM
WRXtuners Member
 
Join Date: Mar 2013
Location: Virginia
Posts: 3
xxking9 is an unknown
That's the weird thing . Im guessing its the secondary air injection pump. For the cel . But as for over boost clueless
xxking9 is offline  
#5 Old 03-02-2013, 05:28 PM
WRXtuners Member
 
06_hawk_eye's Avatar
 
Join Date: Nov 2012
Location: Pennsylvania
Posts: 699
06_hawk_eye is an unknown
new to the subaru world Have some problems please help :)

If it's the secondary air pump might as well get the whole pump system deleted. Being that one new valve is about 250$. And there's 2 valves. I have a 2006 Wrx as well and threw a air pump valve number one stuck open. Me being new to the Subaru world replaced The first valve it did fix the problem. But now will be cleaning the engine bay out when I get my tune and having that deleted. Personally I'd just get that deleted and have the codes replaced. Others will chime in. Hope that helps sorry it was so long


Sent from AutoGuide.com App
06_hawk_eye is offline  
#6 Old 03-03-2013, 12:11 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Unplug and then plug the system back in. see if resets the valve, if not... remove the garbage.

The silencer delete ill not mess with your warranty AFAIK

As far as the spike, you have some looking around on your car my friend.

Paul
2007 XT
2007 MS3
pzr2874 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On