Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Newbie Forum (http://www.wrxtuners.com/forums/f51/)
-   -   new to the subaru world Have some problems please help :) (http://www.wrxtuners.com/forums/f51/new-subaru-world-have-some-problems-please-help-33660/)

xxking9 03-01-2013 09:21 PM

new to the subaru world Have some problems please help :)
 
Hello everyone i just purchased my first subaru 06 wrx from carmax yesterday, it took me a few days to get the car because they had to install a new Air pump. along with tires. when i picked up the car the check engine light was on but all the techs had gone home. i ran the code and it was a secondary air intake code and a air intake solenoid code. i cleared them and the lights stayed off for an hour or so. when i came back outside to go for another spin around the block:sneaky: the light was back on.WTF after i let it warmed up i did a healthy but not retarded 1st to 2nd gear pull then....... my cruise light started flashing along with the lights that illuminate mileage and outside temp. however when the headlights are off the mileage and outside temp lights don't flash. as this is my first wrx i do not know how its is supposed to feel, but have owned several boosted cars this one seems to lag a little and kinda hesitate at first. i have looked through the forums i see alot of similar things with boost creep and aftermarket exhaust and down pipes not being tuned. My car is 100% bone stock. everything! factory minus a crap sony head unit. any ideas? i tried taking the battery loose for 30 mins and restarting it all went back to normal for a min then call came back on.

any info would help me out alot !Thumbs Up.i will have more questions but i don't want to get ahead of myself asking questions about stuff that doesn't matter until this is fixed.

Also does anyone know if i do the intake silencer mod will that terminate my warranty.

xxking9 03-01-2013 11:02 PM

Just got told its common and it sounds like im hitting fuel cut and boost spike to 15ish psi but it shouldnt if the car is as stock as it is, also possible someone left a partial tune on it when they sold it to carmax any opinions???? anyone??????? anyone?????:confused:

brfatal 03-02-2013 02:44 PM

Clearing the CEL is pointless as that doesn't fix the cause. I can't say I've heard of a stock car overboosting and hitting fuel cut.

xxking9 03-02-2013 03:34 PM

That's the weird thing . Im guessing its the secondary air injection pump. For the cel . But as for over boost clueless

06_hawk_eye 03-02-2013 05:28 PM

new to the subaru world Have some problems please help :)
 
If it's the secondary air pump might as well get the whole pump system deleted. Being that one new valve is about 250$. And there's 2 valves. I have a 2006 Wrx as well and threw a air pump valve number one stuck open. Me being new to the Subaru world replaced The first valve it did fix the problem. But now will be cleaning the engine bay out when I get my tune and having that deleted. Personally I'd just get that deleted and have the codes replaced. Others will chime in. Hope that helps sorry it was so long


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com App[/url][/color]

pzr2874 03-03-2013 12:11 AM

Unplug and then plug the system back in. see if resets the valve, if not... remove the garbage.

The silencer delete ill not mess with your warranty AFAIK

As far as the spike, you have some looking around on your car my friend.


All times are GMT -5. The time now is 06:50 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.