Lost pick up power. Vacuum line? Turbo? Anyone what it could be? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 11-08-2012, 02:18 AM Thread Starter
WRXtuners Member
 
Join Date: Nov 2012
Location: California
Posts: 2
NR_MIKO is an unknown
Lost pick up power. Vacuum line? Turbo? Anyone what it could be?

So I was driving my sti this afternoon. As I tried to speed up into traffic the car kinda stalled but didn't die. Just totally lost power. I drove it back home immediately so before I take it into subaru, seeing if you guys would know what it could be? Even the car sounds less powerful. My exhaust would echo my garage and no it sounds too quiet...
NR_MIKO is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-08-2012, 06:50 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,979
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Boost leak probably since it happened while getting on it. Still under warranty?

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
post #3 of 4 Old 11-08-2012, 02:46 PM Thread Starter
WRXtuners Member
 
Join Date: Nov 2012
Location: California
Posts: 2
NR_MIKO is an unknown
Yeah it's still under warranty I guess I should take it in huh?
NR_MIKO is offline  
post #4 of 4 Old 11-08-2012, 05:20 PM
WRXtuners Member
 
Join Date: Oct 2012
Location: New York
Posts: 23
Dsr5dragon is an unknown
Well, id see if the boost leaks from a quick fix stand point first if you cant find a solution be it a bose or loose clamp etc than take the hour or two and have subaru look it over. Either way your car will be good as new soon
Dsr5dragon is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome