Clutch Noise - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 11-03-2009, 12:31 PM
WRXtuners Member
 
PdxRex's Avatar
 
Join Date: Aug 2009
Location: Oregon
Posts: 40
PdxRex is an unknown
Clutch Noise

Noticing a sqweel when clutch is pressed in, only happens at start up and lasts about five minutes or so thens goes away, has this happened to anyone else before. Also does anyone know if they upgraded the clutch on the 09's ?
PdxRex is offline  
Sponsored Links
Advertisement
 
#2 Old 11-03-2009, 12:39 PM
WRXtuners Member
 
Join Date: Apr 2008
Location: New York
Posts: 454
Images: 1
VisiX is a helpful contributing member
Squealing sound from the clutch usually indicates a problem with the throwout bearing. The dealership should cover this under warranty, the clutch is a wear item so you have until 36k miles to get it fixed.

Also could be the master cylinder...

Ryan
2009 STi - Cobb Stage 2
VisiX is offline  
#3 Old 11-04-2009, 09:12 AM
WRXtuners Member
 
allvolwrx's Avatar
 
Join Date: Nov 2009
Location: Tennessee
Posts: 69
allvolwrx is more helpful than not
I have a squeek when i press mine in. I can only hear it when the engine is not running. How can I fix this PB blaster or WD 40?
allvolwrx is offline  
#4 Old 11-04-2009, 11:54 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,973
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
^^ Check your fluid first. If that is ok, lube the cable w/grease of some sort (not gobs)

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
#5 Old 11-16-2009, 08:52 PM
WRXtuners Member
 
Join Date: Apr 2009
Location: Colorado
Posts: 65
Exarch is more helpful than not
@Pdx

I'd second the throwout bearing suggestion.

@allvol

My 07 WRX does the same thing, I'd search around a bit, apparently there is a return spring in the clutch actuation assembly that can be lubed up to quiet this.

I'd do it to my own, but it's just going to start squeaking again anyhow, and it doesn't hurt anything in the mean time...
Exarch is offline  
#6 Old 12-01-2009, 04:06 PM
WRXtuners Member
 
SWFL Scooby's Avatar
 
Join Date: Jun 2007
Location: Florida
Posts: 232
Images: 5
SWFL Scooby is an unknown
I have the exact problem in my 07 with 25k. Annoying in the morning but goes away after a few minutes (when the car warms up). It seems to be worse on humid mornings, which we have no shortage of in FL. There does not seem to be deteriorating performance of the clutch though...

D-Rock
Under constant pressure
SWFL Scooby is offline  
#7 Old 12-16-2009, 01:45 PM
WRXtuners Member
 
PdxRex's Avatar
 
Join Date: Aug 2009
Location: Oregon
Posts: 40
PdxRex is an unknown
Thanks for the ideas everyone. Weird thing is it went away for a couple weeks then the past three days same thing. Right at start up and when I am letting the clutch out SQEEEEL. Guess I have to take it back to the dealer.
PdxRex is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On