2011 WRX Limited - Iphone/iPod integration - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 08-27-2011, 01:02 PM
WRXtuners Member
 
Join Date: Aug 2011
Location: California
Posts: 1
Gonzo is an unknown
2011 WRX Limited - Iphone/iPod integration

Hi,

Please forgive me if this has been already answered somewhere on this forum. I tried a couple of searches and could not find this topic addressed.

I just purchased a 2011 WRX Limited which has the Type C Audio package. I have an iPhone 3GS, and I have successfully paired the unit up via Bluetooth for telephony purposes. This works fine. However, when I connect the unti via cable to the USB connector in the center console and try to use the iPhone as an iPod, strange things happen...

The phone is recognized as an iPod, and I can hit the CD/AUX button to get the "iPod" display on the audio head unit just fine. From here I can successfully navigate around playlists, genres, artists, etc, and select tunes, albums to play. However, when I actually try to get it to play, only very rarely do I get audio. The display indicates that the time is proceeding within the song, and navigation still works. I have only actually gotten audio out a couple of times in this mode and I'm still not sure why/how that happened.

However... when I hit the CD/AUX button again, the head unit displays BT-A, and I can consistently hear the music from the iPhone. Unfortunately, I get no track information at all and I cannot navigate further in this mode.

Does anyone know how the heck this is supposed to work?!?! It's certainly not supposed to work this way, is it??

Thanks in advance for any help you can offer.

= Ed =
Gonzo is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On