08 wrx at dealer. Looks clean and stock, no heat shield. - Page 2 - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
post #16 of 19 Old 11-26-2012, 01:34 PM Thread Starter
WRXtuners Member
 
Join Date: Nov 2012
Location: North Dakota
Posts: 10
Derrrr is an unknown
Well after a week of waiting for parts I think it's fixed. I installed the new denso rear 02 sensor and also installed the n1 style srs catback, which was perfect fit and perfect sound. Even though its probably gonna rust out, anyways I cleaned the maf sensor and took off the battery terminals and flashed brights a few times and hit brakes. After install and putting everything back together it seemed to not wanna come back. It's been 2 days and no light which Is 10 times longer than it ever would go after being cleared. I imagine the previous owner had it modified and screwed sensor up going back to stock seeing as the oem exhaust had shiny silver nuts and bolts and no heat shield. Ill post pics once I get it a bath
Derrrr is offline  
Sponsored Links
Advertisement
 
post #17 of 19 Old 11-28-2012, 08:27 PM
WRXtuners Member
 
Kfnkmac's Avatar
 
Join Date: Apr 2012
Location: Maryland
Posts: 5
Kfnkmac is an unknown
Bought an 08 wrx with the same mileage for about 4 grand less than you paid, think the dealer got you on that one
Kfnkmac is offline  
post #18 of 19 Old 11-28-2012, 08:28 PM
WRXtuners Member
 
Kfnkmac's Avatar
 
Join Date: Apr 2012
Location: Maryland
Posts: 5
Kfnkmac is an unknown
Bought an 08 wrx with the same mileage for about 4 grand less than you paid, think the dealer got you on that one


Sent from my iPhone using AutoGuide.com App
Kfnkmac is offline  
post #19 of 19 Old 02-15-2013, 07:34 AM
WRXtuners Member
 
mickeymxl81's Avatar
 
Join Date: Feb 2013
Location: Georgia
Posts: 3
mickeymxl81 is an unknown
Garage
I got a 2008 subaru WRX brand new and paid 24K in 2008...sorry dude but dont feel too bad...you did buy one bad ass f**in car!!!
mickeymxl81 is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome