07 Fozzy XT Limited - Page 2 - Subaru WRX Forum
 7Likes
Reply
 
LinkBack Thread Tools Display Modes
#16 Old 01-05-2012, 06:06 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,973
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Thing is, this tech has been there for 15 years. Anyways, got the car back yesterday evening and it feels much better. After dropping $37 for a tranny filter () and getting 4 oil filters for free for the hassle I'm going to go beat on it a bit to see if anything else comes up and then take it for the BG flush and fill.

I can't see the youtube video here at work, I'll chk it out later. Thanks.

Speaking of which, anyone watch that TiC video yet ? Funny as hell.

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
Sponsored Links
Advertisement
 
#17 Old 01-05-2012, 07:33 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,371
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
Nope...put up a link on the TiC Video.

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
#18 Old 08-10-2012, 05:51 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,973
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Ok, did a few things for maintainence and was NOT impressed by anything.

I didn't take pics as I was steamed.

07/12
Took the IC off to clean the TB and have a look around.

The IC had a 1/8 of an inch of oil (dried) in it. Thought I would clean the IC with degreaser and the likes and looked up and saw my old 07wrx IC with 3K on it.... Hmmm.... threw the old one in the friggin trash and made out like a bandit with the old one.

Disconnected ALL the vac lines and replaced em all except the long metal line that runs along the IC (douched it with degreaser).

04/12 - 06/12
Changed ALL the diff fluids and was not impressed by the amount of front diff fluid that came out (just short of a Gallon).... Should only take .8-.9 of a quart.... How can this be? Well, after getting some feed back on subaruforester.org they thought I had a seal issue from the tranny. Easy way to find out was to drain the fluids and change em out to a cheap 75-90 fluid for a week and drain it again and see if had a reddish tint (It didn't). So I filled them with it Mobil1 (clear'ish fluid) and will give it a few months and do it again (nice winter maint. garage time since we have no winters here).

04/12
I installed the ghetto Lamco boost gauge I had laying around. No problems at all for a few days and then the light doesn't come on. Replaced the fuse (cig lighter) and sent the wife on her way. A few days later it goes out again (fuse). Not sure why I'm burning fuses out as the LED light pulls close to nothing as far as power. Any ideas for this? Tapping that line was a MOFO as there is little to no room unless you have 2yr old little girl hands (which I don't).

04/12-06/12
Trying to get the hesitation under load to go away and turned to ol'faithful (SF and B12) and began doing the treatments along with a few tankfuls of 80/20 (93/eth). Sure enough it slowly went away and haven't had a stutter/judder since. This could be due to me shit-canning the TMIC and cleaned everything up. Who knows.

Anyhow, just thought I'd update the fun I've had.

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
#19 Old 08-10-2012, 05:53 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,973
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
I'll get that TiC video, I keep forgetting. It's hilarious

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
#20 Old 08-10-2012, 10:52 AM
WRXtuners Member
 
Hondafan's Avatar
 
Join Date: Nov 2006
Location: Utah
Posts: 531
Images: 2
Hondafan is a helpful contributing member
Quote:
Originally Posted by pzr2874 View Post
04/12
I installed the ghetto Lamco boost gauge I had laying around. No problems at all for a few days and then the light doesn't come on. Replaced the fuse (cig lighter) and sent the wife on her way. A few days later it goes out again (fuse). Not sure why I'm burning fuses out as the LED light pulls close to nothing as far as power. Any ideas for this? Tapping that line was a MOFO as there is little to no room unless you have 2yr old little girl hands (which I don't).



Anyhow, just thought I'd update the fun I've had.
Just because it's an LED doesn't mean that all the wiring leading to that LED aren't shorting out and blowing the fuse. Try tapping into a different line for the power. Try running to O'Reilly and get one of these to have it on its own circuit too.

Quote:
Originally Posted by pzr2874 View Post
04/12-06/12
Trying to get the hesitation under load to go away and turned to ol'faithful (SF and B12) and began doing the treatments along with a few tankfuls of 80/20 (93/eth). Sure enough it slowly went away and haven't had a stutter/judder since. This could be due to me shit-canning the TMIC and cleaned everything up. Who knows.
What's your 93/Eth mixture? Do you just run it super hot to clean it? I'm thinking of this as a solution to my brother's MDX that's bogging down really badly, but I'd like to hear more first before suggesting it.

____________________________________
-Brad
Hondafan is offline  
#21 Old 08-10-2012, 11:06 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,973
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Quote:
Originally Posted by turmic View Post
Nope...put up a link on the TiC Video.
Here's that vid... Enjoy


Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
#22 Old 08-10-2012, 11:27 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,973
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Quote:
Originally Posted by Hondafan View Post
What's your 93/Eth mixture? Do you just run it super hot to clean it? I'm thinking of this as a solution to my brother's MDX that's bogging down really badly, but I'd like to hear more first before suggesting it.
I'll try to tap elsewhere, although it's hard to hit anything under there.

It's a 15.9-16.0 gal tank. I ran 2 gal e85 and remainder 93oct.

BUT

I did many other things to remedy this.... MAF cleaning, TB cleaning, SF treatments in the BB and b12 in tank... Placebo? Dunno, as I did these at different times.

Although...

I have heard of MMO in the tank at increments to solve some lubrication issues.

Never attempted this on a Suby, but am considering it on my Speed as I'm starting to tune for e85

My first guess on the Acura would be injectors

It's not a 1st gen MDX is it?

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
#23 Old 08-14-2012, 10:20 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,371
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
That video was pretty funny

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
#24 Old 11-11-2012, 07:57 AM
WRXtuners Member
 
BLAZE2099's Avatar
 
Join Date: Jan 2011
Location: Pennsylvania
Posts: 2,602
Images: 6
BLAZE2099 is known to be trustworthy and helpful BLAZE2099 is known to be trustworthy and helpful
I was google searching fozzys since the wife wants to trade the caliber for a new one. And this thread was one of the top given in the search... Weird?
Still waiting on those pics paul

Randy-
2002 blaze WRX- sold:(
2004 Wrx-sold
2011 Wrx limited
99 Fozz- sold
Eagle eye crew
BLAZE2099 is offline  
#25 Old 11-12-2012, 05:41 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,973
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
haha, I never did take pics...lol

I'll do it this week/weekend. You MIGHT want to wait for the 2014 Foz. Nicer than the previous 5 years. http://www.autoblog.com/photos/2014-subaru-forester/

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
#26 Old 12-07-2012, 05:59 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,973
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Oops... forgot pics.... And I just washed/waxed it a couple weeks ago. *Have another beer Paul*

Anyways.... This airbox has been giving me a headache since I bought the car. First the tab holders on the bottom piece of the box (replaced from a friend's Baja) and now the top piece the MAF bolt holes (apparently a friggin gorilla torqued the MAF screws) and the plastic that surrounds the seats cracked on both. After throwing a couple codes and going into limp mode, I cleaned the MAF again and it finally sat correctly in it's place.

If anyone has a top piece to sell for a good price PM me a $ shipped to 78245.

Oh, and now the LED went out on the gauge but the fuse is still good.... wtf

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
#27 Old 06-23-2013, 06:27 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,973
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Ok..... I'm tired of playin the mechanic in this game.... Need your guys help.... Here are the pics from 1.5 yrs ago
Attached Images
 

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
#28 Old 06-23-2013, 06:33 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,973
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
I'm getting occilation... and I don't know what it's from
Attached Images
 

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
#29 Old 06-23-2013, 06:35 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,973
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
and it's pissin me off. It felt like it was going away when I did 2g E85/rest 93 but I could be wrong....

Help me understand this.... I'm about to change the plugs out.....

Finishing up from last night.... edit:

It feels as if the boost is coming on and then it dips, then comes on and then dips again. I'm watching the boost gauge and I can also feel it a little. I don't want to switch the turbo out (even though it has 98K on it) and it not be the problem.

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3

Last edited by pzr2874; 06-24-2013 at 06:39 AM.
pzr2874 is offline  
#30 Old 07-26-2013, 08:41 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,973
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Getting moisture/water in the passenger side headlight casing.... Subaruforester.org has some nice write-up's on it. will post b4 and after pics (along with links to what I use).... I've already tried to take out the bulbs and look at the seals... nada... they all look good.

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On