02 wrx needing help - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 03-28-2013, 03:59 PM
WRXtuners Member
 
Join Date: Mar 2013
Location: Oklahoma
Posts: 5
jkimb01c is an unknown
02 wrx needing help

I have a 02 wrx im new to these cars
ill give you the low down on the car first it has 140500 miles and got it from someone in Stillwater ok and the mods it has are a turbo back 3" exhaust cat deletes all through and it has upgraded turbo and has been tuned alittle but will be buying a acessport and getting the car tuned in april hard to find awd dynos in Oklahoma. I plan on keeping it w daily driver but with some mods for fun. im enjoying m Subaru a lot and its fun to drive.

im trying to figure out where the bank 1 o2 sensors are because its running rich and im trying to get it running right.. also can you guys recommend anything else I can do to make it run before

I know changing spark plugs but what brand..

I do have experience with imports I used to own a 98 eclipse gsx with mods but just wanna make sure im doing everything right with this car..

ill post pics of the car soon
Attached Images
     

Last edited by jkimb01c; 03-29-2013 at 08:15 AM.
jkimb01c is offline  
Sponsored Links
Advertisement
 
#2 Old 03-29-2013, 05:19 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,962
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
NGK is the plug you want... Next step colder.... What charger is on there now?

Here's a decent link: Subaru Impreza WRX 2002 Oxygen (02) Sensor Replace - WikiAuto

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#3 Old 03-29-2013, 08:07 AM
WRXtuners Member
 
Join Date: Mar 2013
Location: Oklahoma
Posts: 5
jkimb01c is an unknown
its a vf34 turbo now and any specific ngk, platinums or copper? ahh so the bank 1 o2 sensors are on the exhaust headers by the left wheel (if your looking at the motor)? that's what I looks like to me. so are there 2 o2 sensors on bank 1 or is it just one and its the top plug?
jkimb01c is offline  
#4 Old 03-29-2013, 09:02 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,962
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Coppers are fine but need to be switched out WAY more often. After doing it once or twice WITH the right tools, you should be able to do it in an hour or so. I recomend the NGK Iridiums NGK Iridium Spark Plugs One Step Colder 2667 Subaru WRX 2002-2005 at RallySportDirect.com

But do yourself a favor and get the part# and call your local O Reilly's and get em for $10 cheaper and no shipping.

It should have 2. The other one is located on/in the midpipe after the downpipe. The front one is considered a narrowband , the rear is standard.

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#5 Old 03-29-2013, 09:38 AM
WRXtuners Member
 
Join Date: Mar 2013
Location: Oklahoma
Posts: 5
jkimb01c is an unknown
could the fact that the wideband o2 sensor cause idle lag(aka bad idle) abit I know it needs a tune for the exhaust and the upgraded turbo but it doesn't have cats and the cel shows that bank 1 keeps running lean and rich.. could it be because the wideband o2 is out?
jkimb01c is offline  
#6 Old 03-29-2013, 10:16 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,962
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
You have a way to log?

It prob just needs a tune. Another reason buying a modded car is sometimes a nightmare.

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#7 Old 03-29-2013, 10:59 AM
WRXtuners Member
 
Join Date: Mar 2013
Location: Oklahoma
Posts: 5
jkimb01c is an unknown
well I go to autozone just to look at the codes to make sure that it isn't miss firing and check to see if the cel changes.. it goes from being to rich to too lean and also the cats are on the car.. it also has a cold air intake on fyi but the o2 sensors are looking really old but theres not telling when the car had them changed though..
jkimb01c is offline  
#8 Old 03-29-2013, 11:15 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,962
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
They do go out often on wrx's.

So it does have a rough idle?

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#9 Old 03-29-2013, 11:23 AM
WRXtuners Member
 
Join Date: Mar 2013
Location: Oklahoma
Posts: 5
jkimb01c is an unknown
it does have alittle bit of a rough idle but I think its because the bank 1 o2 sensor is out because it running way rich.. I did the oil change yesterday and I smelt gas.. it does have a bov which I plan on taking off and replacing it with the stock original one.. I read a lot that they are bad for engines.. is this true?
jkimb01c is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On